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Preface

This book is for beginners to intermediate users of LibreOffice 
Writer who want to produce a book-length document such as a 
novel, a collection of poetry or essays, or a non-fiction book, and 
then self-publish the book using an online service such as Amazon’s 
Kindle Direct Publishing, Lulu, or the like.

Why use LibreOffice?
People use LibreOffice for several reasons:

• No licensing problems. You can put the program on as 
many computers as you wish, and give away copies to as 
many people as you wish. LibreOffice does not need to be 
activated or registered, and it never “phones home” unless 
you have told it to do so—to check for updates, for example.

• No cost. You never have to pay for a copy, if you download it
from the official website.

• Multi-platform. It works on Microsoft Windows, Apple’s 
macOS, and GNU/Linux.

• File compatibility. You can open and save to many file 
formats, including Microsoft Office formats, in addition to 
the default OpenDocument format.

• Built-in export to PDF (Portable Document Format). You 
do not need to use another program to create PDFs, unless 
your printing service requires you to do so.

• Built-in export to EPUB, a popular ebook format. You 
may also need to use the free open-source program Calibre to 
clean up any formatting problems and to convert EPUB to 
MOBI (for Kindle) and other formats.
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What do you need to do first?
This book assumes that you have successfully installed LibreOffice 
on your computer, and that you know how to create, edit, and save 
files. Although this book was written for LibreOffice 6.3, most of the
information is relevant to other versions of LibreOffice. Some 
details may vary with the version and with your operating system.

If you do not already have a copy of LibreOffice, or if you want to
upgrade to the latest version, go to http  s  ://www.libreoffice.org/   to 
download a free copy.

You may also want to install Calibre, available from 
https://calibre-ebook.com/ and GIMP (https://www.gimp.org/).

Using LibreOffice on a Mac
Some keystrokes and menu items are different in macOS from those
used in Windows and Linux. The table below gives some common 
substitutions for the instructions in this book. For a more detailed 
list, see the application Help.

Windows, Linux macOS equivalent Effect

Tools > Options 
menu selection

LibreOffice > 
Preferences

Access setup options

Right-click Control+click and/or 
right-click depending 
on computer setup

Open a context menu

Ctrl (Control) ⌘ (Command) Used with other keys

F5 Shift+⌘+F5 Open the Navigator

F11 ⌘+T Open Styles in the sidebar

Tip
If you’re a Mac user, and your primary purpose is publishing, 
you may prefer to use one of Apple’s free (but not open source) 
publishing programs, Pages and iBooks Author. But if you use 
LibreOffice for other everyday work, you may prefer to explore 
its publishing capabilities.
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What you see may be different
The illustrations in this book were mainly taken from a MacBook 
running macOS Mojave. Therefore, some illustrations may differ 
slightly from what you see on your computer display.

Terminology
The terms used in LibreOffice for most parts of the user interface 
(the parts of the program you see and use, in contrast to the code 
that makes it work) are the same as for most other programs.

A dialog is a special type of window. Its purpose is to inform you
of something, or request input from you, or both. It provides 
controls for you to use to specify how to carry out an action.

In most cases, you can interact only with the dialog—not the 
document itself—as long as the dialog remains open. When you 
close the dialog after use (usually, clicking OK or another button 
saves your changes and closes the dialog), then you can again work 
with the document.

Some dialogs can be left open as you work, so you can switch 
back and forth between the dialog and your document. An example 
of this type is the Find & Replace dialog.

For more on self-publishing
This book introduces Writer as a tool for preparing a PDF for a self-
published book, but it does not cover other aspects of the printing 
and publishing process or specifics of the various print-on-demand 
services. Nor does it discuss some important decisions you need to 
make regarding the design of your book.

You can find numerous books on these topics. Bruce Byfield’s
Designing with LibreOffice is an excellent resource on design and 
discusses the use of styles and templates in greater detail than in 
this book. Get it here: http://designingwithlibreoffice.com/ 

This book also covers producing an ebook (EPUB) from a Writer 
file, either using Writer itself, or in conjunction with the open-
source program Calibre, available from https://calibre-ebook.com/. 
Ebook design and production is also discussed in Bruce Byfield’s 
forthcoming book, Designing Ebooks.
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Part 1: Essentials

The first eight chapters of this book cover topics that every self-
publisher needs to know about using LibreOffice Writer for 
writing and publishing of books.

1   Introduction to Writer
2  Set up Writer
3  Write and edit
4  Design your book using Writer’s styles
5  Format pages
6  Format text
7  Create PDFs and covers
8  Create ebooks

The eight chapters in Part 2: Extras (beginning on page 113) 
cover topics that may be relevant to your book, your use of 
LibreOffice Writer, or your choice of self-publishing service, but 
are not needed by everyone.





1 Introduction to Writer

Writer is the word processing component of LibreOffice. It provides 
the usual features of a word processor, including a spelling checker, 
thesaurus, hyphenation, autocorrection, and find and replace. It 
also has many important features that are of interest to self-
publishers:

• Powerful page layout
• Easy-to-use templates and styles
• Export to PDF and EPUB
• Placement of pictures and graphics
• Automatic creation of tables of contents and indexes
• Tracking of changes during editing
Learning how to use Writer to create, edit, and manage 

documents is an important first step. This chapter introduces these 
basics.

Writer is similar to Microsoft Word, but it is also different. If you
are familiar with Word, you may need to learn some new ways when
you work in Writer. If you can’t find a certain feature in Writer, 
don’t assume that feature is not there. Writer might handle it 
differently.

The Writer workspace
The most commonly used view of the main Writer workspace (called
“Normal”) is shown on the next page.

Title bar and Menu bar
The Title bar shows the file name of the current document. When 
the document is not yet named, the document name will appear as 
Untitled X, where X is a number. Untitled documents are numbered
in the order in which they are created.

Chapter 1  Introduction to Writer 17



The Menu bar is located just below the Title bar in Windows and 
Linux and at the top of the screen in macOS. When you select one of
the menus, a submenu drops down to show further options.

Sidebar
The sidebar in Writer contains five decks by default: Properties, 
Page, Styles (shown as Styles and Formatting in some installations), 
Gallery, and Navigator. Each deck can be opened by clicking its 
corresponding icon on the Tab bar to the right of the sidebar.

Two additional decks are available: Manage Changes and 
Design. You can enable these decks by choosing them on the 
Experimental Features page in Tools > Options > LibreOffice > 
Advanced.

A sidebar deck is like a combination of a toolbar and a dialog. 
For example, you can freely mix working in the main edit window to
enter text and use the Properties deck in the sidebar to change text 
attributes. Some decks contain a More Options button, which opens 
a dialog with additional editing controls.

Toolbars and sidebar decks share many functions. For example, 
the buttons for making text bold or italic exist in both the 
Formatting toolbar and the Properties deck.
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Toolbars
Most of Writer’s toolbars can be either docked or floating. They can 
be moved to different locations (top, side, bottom) in the Writer 
workspace. They can even be floated outside the Writer window.

The top toolbar is called the Standard toolbar. All LibreOffice 
components (Writer, Calc, Draw, Impress, Base) have this toolbar.

The second toolbar at the top is the Formatting toolbar. It shows 
tools related to the selection or the cursor’s position. For example, 
when the cursor is in text, the tools shown are Writer’s text 
formatting tools. When a graphic is selected, the Formatting toolbar 
shows tools for formatting graphics.

To free more space for the document, you can choose a single-
toolbar alternative containing the most-used commands. To activate
it, enable View > User Interface > Single Toolbar.

Writer also provides several alternative toolbar arrangements, 
which you can find on the View > User Interface menu.

Several other toolbars normally appear only when the context 
requires them. For example, when the cursor is in a table, the Table 
toolbar appears. When the cursor is in a list, the Bullets and 
Numbering toolbar appears.
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To display or hide toolbars, choose View > Toolbars, then 
click on the name of a toolbar in the list. An active toolbar has a 
checkmark next to its name.

To move a docked toolbar, click on its handle and drag it to the 
new location. To move a floating toolbar, click on its title bar and 
drag it to the new location. Floating toolbars dragged to a docking 
location change into docked toolbars.

Customizing toolbars
You can choose which icons are visible on a toolbar. You can also 
add icons and create new toolbars, as described in Chapter 15.

To customize a toolbar, right-click between the icons on the 
toolbar. A menu drops down.

 Choose Visible Buttons from this menu to open a submenu. 
Visible icons are indicated by a border around the icon or a 
checkmark by the icon (depending on your operating system). Click 
on an icon to select or deselect it.

Right-click (context) menus
You can quickly access many menu functions by right-clicking on a 
paragraph, a graphic, or another object. A context menu will pop up.
Often the context menu is the fastest and easiest way to reach a 
function. If you do not know where to find a function in the menus 
or toolbars, you can often find it by right-clicking.

20 Chapter 1  Introduction to Writer



Status bar
The Writer status bar provides both information about the 
document and convenient ways to quickly change some document 
features. From left to right, the fields are as follows.

Left end of status bar

Page number
Shows the current page number, the sequence number of the 
current page (if different), and the total number of pages in the 
document. If you restarted page numbering at 1 on the third page, 
then its page number is 1 but the sequence number of that page is 3.

If any bookmarks have been defined in the document, a right-
click on this field pops up a list. Click on the required bookmark to 
jump to that location in the document.

To jump to a specific page in the document, click on this field. A 
small dialog opens. Type the sequence number of the required page. 
The display jumps to that page.

Word and character count
Shows the number of words and characters in the document, 
updated as you edit. If you select some text, the count for that 
selection will temporarily replace the total count for the document.

By default, the character count includes spaces. To display the 
character count excluding spaces, double-click the word count in the
status bar, or choose Tools > Word Count. A small dialog opens.

Page style
Shows the style of the selected page. To change the page style, right-
click on this field. A list of page styles pops up; choose a different 
style by clicking on it. To edit the current page style, double-click on 
this field; the Page Style dialog opens.

Caution
Changing the page style here may affect the styles of following 
pages, depending on how the page styles are set up. See Chapters
4 and 5 for details about page styles.
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Language
Shows the language and localization used for spelling, hyphenation, 
and the thesaurus, based on the position of the cursor or the 
selected text. Click to open a menu where you can choose another 
language for the selected text or for the paragraph where the cursor 
is located. You can also choose None (Do not check spelling). 
Choose More to open the Character dialog.

Insert mode
This area is blank when in Insert mode. Click to change to Overwrite
mode; click again to return to Insert mode.

Selection mode
Right-click to choose different selection modes. The icon does not 
change, but a tooltip indicates which mode is active. See the Writer 
Guide for more information about these modes. Normally you 
would use Standard.

Document status
Different icons appear here if the document has unsaved changes or 
if all changes have been saved. A tooltip also indicates the status.

Right end of status bar

Digital signature
An icon appears here if the document has been digitally signed. 
Double-click the icon to view the certificate.

Object information
When the cursor is in a section, heading, or list item, or when an 
object (such as a picture or table) is selected, information about that
item appears in this field. Double-clicking in this area opens a 
relevant dialog.

View layout
Choose an icon to change between single page, side-by-side, and 
book layout views. You can edit the document in any view.
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Zoom settings interact with the selected view layout and the 
window width to determine how many pages are visible in the 
document window.

Zoom
To change the view magnification, drag the Zoom slider or click on 
the + and – signs or right-click on the percent field to pop up a list 
of choices.

You can also double-click on the percent field to open the Zoom 
and View Layout dialog.

Changing document views
Writer provides three ways to view a document: Normal, Web, and 
Full Screen. To change the view, go to the View menu and click on 
the desired view. (When in Full Screen view, press the Esc key to 
return to either Normal or Web view.)

When in Normal view, you can use both the Zoom slider and the 
View Layout icons on the status bar. In Web view, you can use only 
the Zoom slider.

You can also choose View > Zoom > Zoom from the menu bar
to display the Zoom & View Layout dialog, where you can set the 
same options that are on the status bar. In Web Layout view, most 
of the choices are not available.
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Using the Navigator
In addition to the Page Number field on the status bar (described on
page 21), Writer provides other ways to move quickly through a 
document. The many features of the Navigator, the Navigation 
toolbar, and related icons help you find specific items in a 
document.

The Navigator lists all of the headings, tables, text frames, 
graphics, bookmarks, and other objects contained in a document.
To open the Navigator, click its icon on the sidebar.

In the list of categories, click the + sign by any of the lists to 
display the contents of the list.

The icons at the top of the Navigator have the effects described 
below.

Navigation: Opens the Navigation toolbar (see page 25).

Previous, Next: Jumps to the previous or next item in the 
document. To select the category of items, see page 25.

Page Number: Jumps to the page number in the box. Type the 
page number or select it using the up and down arrows.

Drag Mode: Select hyperlink, link, or copy.

Content Navigation View: Switches between showing all 
categories and showing only the selected category.
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Set Reminder: Inserts a reminder (see page 26).

Header, Footer: Jumps between the text area and the header 
or footer area (if the page has them).

Anchor<->Text: Jumps between a footnote anchor and the 
corresponding footnote text.

Heading Levels Shown: Choose the number of levels.

The other icons refer to advanced features not covered here.

Move quickly through a document
The Navigator provides several convenient ways to move around a 
document and find items in it:

• To jump to a specific page in the document, type its sequence 
number in the box at the top of the Navigator.

• When a category is showing the list of objects in it, double-
click on an object to jump directly to that object’s location in 
the document.

• To see the content in only one category, highlight that 
category and click the Content Navigation View icon. 
Click the icon again to display all the categories. You can also 
change the number of heading levels shown.

• Use the Previous and Next icons to jump to other objects of
the type selected in the Navigation toolbar. (See below.)

Tip
Objects are much easier to find if you have given them names 
when creating them, instead of keeping Writer’s default names 
of graphics1, graphics2, Table1, Table2, and so on. These default 
names may not correspond to the position of the object in the 
final document.

Use the Navigation toolbar
To display the Navigation toolbar, click the Navigation icon in the 
Navigator (page 24).

The Navigation toolbar shows icons for all of the object types 
shown in the Navigator, plus some extras (for example, the results 
of a Find command).
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Navigation toolbar

Click an icon to select that object type. Now all the Previous and 
Next icons (in the Navigator itself, in the Navigation toolbar, and on 
the Find toolbar) will jump to the next object of the selected type. 
This is particularly helpful for finding items like bookmarks and 
index entries, which can be difficult to see in the text. The names of 
the icons (shown in the tooltips) change to match the selected 
category; for example, Next Graphic, or Next Bookmark.

Set reminders
A little-known and very useful feature of Writer is reminders. 
Reminders let you mark places in your document that you want to 
return to later on, to add or correct information, make some other 
change, or simply mark where you finished editing. The possible 
uses of reminders are limited only by your imagination.

To set a reminder at the cursor’s location, click on the Set 
Reminder icon in the Navigator. You can set up to 5 reminders in a 
document (setting a sixth causes the first to be deleted).

Reminders are not highlighted in any way in the document, so 
you cannot see where they are, except when you jump from one to 
the next—the location of the cursor then shows the location of the 
reminder.

To jump between reminders, first select the Reminder icon on 
the Navigation toolbar or the Find toolbar. Then click the Previous 
and Next icons.

Creating a new document
To create a new, blank document in Writer:

• When LibreOffice is open but no document is open, click the 
Text Document icon in the Start Center, or click the 
Templates icon to start a new document using a template.
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• When a document is already open in Writer:
– Press the Control+N keys, or
– Use File > New > Text Document, or
– Click the New button on the main toolbar.

The new document opens in a new Writer window.

Create a document from a template
A template serves as the foundation of a set of documents, to make 
sure that all documents in the set have a similar layout: the same 
page size, the same headers and footers, the same fonts, and so on.

If you plan to save the chapters of your book as separate files and
combine them into one file at the end, as described on page 28, then
you should base the individual chapters on a template.

To create a new document based on a template, choose File > 
New > Templates, or click the Templates icon in the Start Center. 
In the Templates dialog, choose the required template, and click 
Open. For more about using templates, see Chapter 14.

Saving a document
Writer saves in a file format called  OpenDocument Text (ODT).
To save a document:

• Press Control+S, or
• Use File > Save, or
• Click the Save icon on the main toolbar.

To save a document under a different name, choose File > Save As.

Save as a Microsoft Word document
If you need to exchange files with users of Microsoft Word, you can 
save a document as a Microsoft Word file.

1 Click File > Save a Copy.

2 On the Save a Copy dialog, in the File type drop-down list, 
select the type of Word document you need. Click Save.

This procedure leads to the undesirable situation of having two 
versions of the document on your computer: ODT and DOCX.

You want to keep working with the LibreOffice (ODT) version.
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Combining several documents into a book
One way to build your book is to save each chapter or section in a 
separate document. Reviewers or editors can then deal with 
individual chapters while you work on others.

When the book is complete, you need to combine all the chapters
and other material (title page, copyright page, and so on) into one 
file before final formatting, creating a table of contents, and 
producing a PDF for printing.

To combine files:

1 Open the first file. Ensure that end-of-paragraph marks are 
visible.

2 Go to the last page of the document. If there is no blank 
paragraph at the end, press Enter at the end of the last 
paragraph to create a blank paragraph.

3 With the cursor in the blank paragraph, choose Insert > 
Text from File from the menu bar. A file browser opens.

4 Select the second document and click Open.

5 Wait a few seconds for the file to open and paginate, then 
repeat steps 2 through 4 for the third and subsequent 
documents until all have been included. Save the book under 
another file name.

6 Proceed with final formatting (see Chapter 5).

Note on master documents
LibreOffice has a master document feature for combining a 
collection of files into one file. Although master documents do 
work, they have some quirks that can make them more trouble 
than they are worth for books that are mostly text. Master 
documents are best left for more complex documents. For this 
reason they are not covered in this book.
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2 Set up Writer

This chapter describes how to set up some of Writer’s features. You 
may want to jump right into writing or designing your book, but 
spending a few minutes with this chapter now may save you from 
irritation later.

This chapter does not cover all of the options. See the help file or
the Writer Guide for more information.

Tip
Many options are intended for power users and programmers. 
If you don’t understand what an option does, it’s usually best to 
leave it alone unless instructions in this book recommend 
changing the setting.

Choosing options for all of LibreOffice
On the menu bar, click Tools > Options. If you don’t see the 
subsections in the Options dialog, click the expansion symbol (+ 
sign or triangle) by LibreOffice in the left-hand section.
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User data
Because Writer uses the name or initials stored in the User Data 
page for several things, for example document properties (created 
by and last edited by information) and the name of the author of 
comments and changes, you’ll want to make sure that the correct 
information appears in the fields on this page.

View options
The View options control how the document window looks and 
behaves. Some of the options are described below.

User Interface – Icon size and style
Changes the size and style of toolbar, sidebar, and other icons.

Menu – Icons in menus
Causes icons to appear next to words in menus.
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Font Lists – Show preview of fonts
Shows an example of the font along with the font name. 

(Left) Font list with preview; (Right) Without preview

Print options
Set print options for the default printer and most common printing 
method. Change these settings at any time by using this page or by 
clicking the Options button on the Print dialog during the printing 
process.

In the Printer warnings section near the bottom, you can choose
to be warned if the paper size or orientation in the document do not 
match the paper size or orientation of the printer.
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Tip
If your printouts are coming out incorrectly placed on the page 
or chopped off at the top, bottom, or sides, or if the printer is 
refusing to print, the most likely cause is paper size 
incompatibility. See also “Print options for Writer” on page 38.

Fonts options
If you receive a document containing fonts that you do not have on 
your system, LibreOffice will use substitute fonts for those it does 
not find. On the LibreOffice – Fonts page, you can specify a font 
different from the one the program chooses.

Security options
Use the LibreOffice – Security page to choose security options for 
saving documents and for opening documents that contain macros. 
For information on the options, refer to the Help or to the Writer 
Guide.

Application colors options
Writing, editing, and (especially) page layout are easier when you 
can see the page margins (text boundaries), the boundaries of tables
and sections, grid lines, and other features. In addition, you might 
prefer colors that are different from the defaults of LibreOffice for 
such items as note indicators and field shadings.

• To show or hide things such as text boundaries, select or 
deselect them.

• To change the colors of these items, click the down-arrow in 
the Color setting column and select a color from the drop-
down list.

• To save your color changes as a color scheme, type a name in 
the Scheme box and click Save.

Note 
To change the color settings used in Track Changes mode, go to 
Tools > Options > LibreOffice Writer > Changes (see 
page 40).
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Choosing Save options
In the Options dialog, click the expansion sign (+ or triangle) to the 
left of Load/Save and choose General. Some items are described 
below.

Edit document properties before saving
If this option is selected, the Document Properties dialog pops 
up to prompt you to enter relevant information the first time you
save a new document (or whenever you use Save As).

Always create backup copy
Recommended.
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Save AutoRecovery information every __ Minutes
Choose whether to enable AutoRecovery and how often to save 
the information used by the AutoRecovery process.

Default file format and ODF settings
Document type. If you routinely share documents with users 
of Microsoft Word, you might want to change the Always save 
as attribute for text documents to one of the Word formats. See 
“Save as a Microsoft Word document” on page 27 for more 
information.)

Choosing options for Writer
Settings chosen on the pages in the LibreOffice Writer section of the
Options dialog determine how your Writer documents look and 
behave while you are working on them.

In the Options dialog, click the expansion symbol (+ sign or 
triangle) next to LibreOffice Writer in the left-hand section of the 
dialog. A list of pages drops down.

34 Chapter 2  Set up Writer



Writer general options
Settings on this page control the updating of links and fields, the 
units used for rulers and other measurements, tab stops, and word 
count behavior.

Measurement unit 
Document designers recommend using points as the default 
measurement because you can easily relate things like font size 
to things like indents and tabs.
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Tip
To change the measurement unit of the ruler itself, right-click on
the ruler, then select the desired unit from the pop-up list. This 
change does not change the measurement unit chosen under 
Tools > Options.

Tab stops
The default tab stops setting controls two things: tabs within 
paragraphs and the indentation of entire paragraphs when using
the Increase Indent button on the Formatting toolbar.

Note
Using the default tab stops to space out material on a page is not 
recommended. It may cause major formatting problems. 
Instead, define your own tab stops in paragraph styles or 
individual paragraphs, as described in “Defining your own tabs 
and indents” on page 92.

Word Count – Additional separators
For counting words, specifies the characters that are considered 
to separate words, in addition to spaces, tabs, line breaks, and 
paragraph breaks.

Word Count – Show standardized page count
Editors and publishers often define a “standard” page as 
containing a specified number of characters or words; this field 
allows quick calculation of the number of these pages.

View options
Set the defaults for viewing Writer documents on the two pages 
called View and Formatting Aids.

View is a good page to check when you cannot see expected 
graphics or when you see field codes instead of text or numbers.
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Formatting Aids options
Symbols for tabs and for paragraph ends help you when writing, 
editing, and doing page layout. You might want to know if any tabs 
or blank paragraphs are present or if any tables or graphics extend 
into the margins.
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Note
Direct cursor lets you place text, images, tables, frames, and 
other objects in any blank area on the page. Writer inserts blank 
paragraphs and tabs to position the text or objects. Avoid this 
feature. It is incompatible with the correct use of styles and 
leads to formatting oddities.

Grid options
Snap to grid automatically moves an object to the nearest 
gridlines. This can be helpful when you are trying to align objects 
such as graphics or tables. You can adjust the sizing of the grid and 
you can specify other grid details.

Basic Fonts (Western)
These options are for use when editing web pages. They are not 
relevant here. Set up your fonts in paragraph and character styles.

Print options for Writer
Choose which items are printed with the document by default. 
These options are in addition to those on the LibreOffice – Print 
page (page 31).
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Some considerations:
• When you are working on drafts and you want to save printer 

ink or toner, deselect some of the items in the Contents 
section.

• The Print black selection causes colored text (but not 
graphics) to print as solid black on both color and black-and-
white printers. (On most black-and-white printers, colored 
text and graphics print as grayscale.)
Contrast this setting with Convert colors to grayscale on 
the LibreOffice – Print page (page 31), which causes both 
colored text and graphics to print as greybeard on color 
printers.

• If you are printing double-sided on a non-duplexing printer, 
print only the left or the right pages, then turn the stack over 
and print the other half.

• Depending on how your printer ejects pages (face up or face 
down), you might need to print the pages in reverse order so 
that they stack in the correct order as they are printed.

Tip
You can override any of these defaults when printing a 
document. Click File > Print, then click the Options button on
the Print dialog. The Printer Options dialog that appears is 
similar to the one shown above.
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Table options
Use this page to specify the default behavior of tables.

• If most of your tables will require borders or headings, select 
those options. Otherwise, deselect borders and headings 
here, and add them as needed to individual tables.

• Number recognition can be very useful if most of your tables 
contain numerical data. Writer recognizes dates or currency, 
for example, and formats the numbers appropriately. 
However, if you want the numbers to remain as ordinary text,
deselect this option.

Change-tracking options
If you plan to use the change-tracking feature of Writer (described 
in Chapter 13), use the Changes page to choose how inserted and 
deleted material is marked, whether and how attribute changes such
as bold or italics are marked, and whether and how change bars 
appear in the margins.
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Choosing language settings
You may want to do several things for the language settings:

• Change some locale and language settings
• Choose spelling options
• Choose grammar options

Change some locale and language settings
You can change some details of the locale and language settings that
LibreOffice uses, for all documents or for specific documents.

In the Options dialog, on the left, choose Language Settings >
Languages. On the right, change User interface, Locale setting,
Default currency, and Default languages for documents as required. 
In the example, English (UK) has been chosen for all the settings.

If you want the language (dictionary) setting to apply to the 
current document only, instead of being the default for all new 
documents, select For the current document only.

Here you can also select the options to enable support for Asian 
languages (Chinese, Japanese, Korean) and support for Complex 
text layout languages such as Hindi, Thai, Hebrew, and Arabic.
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Choose spelling options
In the Options dialog, on the left, choose Language Settings > 
Writing Aids. On the right, near the bottom, choose the settings 
that are useful for you.

• If you don’t want spelling checked as you type, deselect 
Check spelling as you type.

• If you use a custom dictionary that uses uppercase words and 
words with numbers, select Check uppercase words and 
Check words with numbers.

• Check special regions is for checking the spelling of 
headers, footers, frames, and tables.

Here you can also check which of the user-defined (custom) 
dictionaries are active. Add or remove dictionaries by clicking the 
New or Delete buttons.
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Choose grammar options
On the Language Settings – English Sentence Checking page, you 
can choose which items are checked for, reported to you, or 
converted automatically. After selecting the additional grammar 
checks, you must restart LibreOffice, or reload the document, for 
them to take effect.
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3 Write and edit

This chapter covers the basics of writing and editing using Writer. 
Formatting, fonts, symbols, and lists are covered in Chapter 6.

• Select, copy, paste, and move text
• Find and replace text
• Check spelling and use the thesaurus
• Use language tools
• Use autocorrection, word completion, and autotext
• Include document information in text

General recommendations
Write and edit before formatting
I recommend that you write, edit, and assemble materials, and then 
use Writer to format your book. Do not format as you write. 
Concentrate on the content when you are in the writing and editing 
stage. (Bruce Byfield takes a different approach, as he describes in 
Designing with LibreOffice. Do whatever works for you.)

Certainly, apply paragraph styles to headings and other elements
as you go, but don’t worry about other layout issues such as spacing,
page breaks, font choices, placement of graphics, and so on.  
Concerns about formatting in this stage will just distract you.

Also, if you need to share drafts with a user of Microsoft Word, 
you can save drafts in Word and receive edits in Word, without 
being concerned about possible formatting incompatibilities.

Spacing of paragraphs and headings
Define spacing between paragraphs in the paragraph style as 
described in Chapter 6.

Do not press Enter several times to create extra space either 
between paragraphs or before and after headings. Doing this might 
create blank paragraphs tagged as headings, which will show up 
with page numbers in the Table of Contents.
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Selecting, copying, and pasting text
The Writer operations of selecting, cutting, and copying text are 
similar to the same operations in other word processors. You can 
copy or move text within a document, or between documents, by 
dragging or by using menu selections, icons, or keyboard shortcuts. 
You can also copy text from other sources and paste it into a Writer 
document.

When you paste text, the result depends on the source of the text
and how you paste it. If you click on the Paste icon, then the pasted 
text keeps its original formatting. If you do not like the results, click 
the Undo icon or press Control+Z.

To make the pasted text take on the formatting of the text 
surrounding where it is pasted, choose either:

• Edit > Paste Special, or
• Click the triangle to the right of the Paste icon, or
• Click the Paste icon and hold down the mouse button.

Then select Unformatted text from the resulting menu.
The range of choices on the Paste Special menu varies depending

upon the origin and formatting of the text (or other object) to be 
pasted.

Moving paragraphs quickly
Click anywhere in the paragraph, then press and hold the 
Control+Alt keys while pressing the up-arrow or down-arrow key. 
The paragraph will move to a new location either before the 
previous paragraph or after the next paragraph. To move more than 
one paragraph at a time, select at least part of all the paragraphs you
want to move before pressing the Control+Alt+arrow keys.

Tip
If your paragraphs suddenly jump from one place to another, the
most likely reason is that you have accidentally pressed one of 
these key combinations.

Finding and replacing text and formatting
Writer has two ways to find text within a document: the Find 
toolbar for fast searching and the Find & Replace dialog.
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Using the Find toolbar
The Find toolbar is usually docked at the bottom of the Writer 
workspace, just above the Status Bar.

Type your search text in the Find box, then press Enter to find 
the next occurrence of that term. Click the Find Next or Find 
Previous arrow buttons as needed. Select Match Case to find only
the instances that exactly match the use of upper and lower case 
letters in the search term. Click the icon next to Match Case to 
open the Find & Replace dialog.

A Navigation box is also found on this toolbar. You can easily 
jump to the next or previous items of the type selected in the box; 
Headings is selected in the example above. 

Using the Find and Replace dialog
You can search for and replace:

• Words and phrases
• Specific formatting (such as bold or italic)
• Paragraph styles
• End-of-paragraph and line break marks

To display the Find & Replace dialog, use the keyboard shortcut 
Control+F or select Edit > Find & Replace.

1 Type the text you want to find in the Search for box.

2 To replace the text with different text, type the new text in 
the Replace with box.

3 You can select various options, such as matching the case, 
matching whole words only, or doing a search for similar 
words. (See the next section for some other choices.)

When you have set up your search, click Find or Find All. To 
replace text, click Replace instead.

Caution
Use Replace All with caution; otherwise, you may end up with 
some highly embarrassing mistakes that might require a manual,
word-by-word search to fix.
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Expanded Find & Replace dialog

Find and replace specific formatting
A very powerful use of Find & Replace takes advantage of the format
option. For example, you might want to replace underlined words 
with italics.

On the Find & Replace dialog (with More Options displayed):

1 To search for specific formatting only, delete any text in the 
Search for box.

To search for text with specific formatting, type the text in 
the Search for box.

2 Click Format to display the Text Format (Search) dialog. 
The tabs on this dialog are similar to those on the Paragraph 
format and Paragraph Style dialogs. 

3 Choose the formats you want to search for and then click 
OK. The names of selected formats appear under the 
Search for box. For example, you might search for all text 
in 14-point bold Helvetica.
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4 To change the formatting, click in the Replace with box, 
then click Format to display the Text Format (Replace) 
dialog. Choose the formats you want, and then click OK.

To leave the text unchanged, and only change the formatting,
leave the Replace with box blank.

To replace text as well as formatting, type the replacement 
text in the Replace with box.

5 To remove specific character formatting, click Format, 
select the Font tab, then select the opposite format (for 
example, No Bold). The No Format button on the Find & 
Replace dialog clears all previously selected formats.

6 Click Find, Find All, Replace, or Replace All.

Tip
Unless you plan to search for other text using the same 
attributes, click No Format to remove the attributes after 
completing your search. If you forget to do this, you may wonder
why your next search fails to find words you know are in the 
document.

Find and replace paragraph styles
If you combine material from several sources, you may discover that
lots of unwanted paragraph styles suddenly show up in your 
document. To quickly replace one (unwanted) style with another 
(preferred) style:

1 On the expanded Find & Replace dialog, select Search for 
Styles. (If you have attributes specified, this option is 
labeled Including Styles.) The Search for and Replace 
with boxes now contain a list of styles.

2 Select the style you want to search for and the style you want 
to replace it with.

3 Click Find, Find All, Replace, or Replace All.

Repeat steps 2 and 3 for each style that you want to replace.
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Find and replace line breaks and paragraph ends
If you paste material from emails or websites, you may find that 
such material often uses two line breaks at the end of a paragraph 
instead of one end-of-paragraph mark. This causes a whole group of 
paragraphs, often including headings, to be treated as only one 
paragraph in Writer, often resulting in major formatting problems.

To change two line breaks into one end-of-paragraph mark:

1 On the Find & Replace dialog, click More Options to see 
more choices. On this expanded dialog, select Regular 
expressions.

2 Type \n\n in the Search for box and \n in the Replace 
with box. Click Find, Find All, Replace, or Replace All.

Tip
When searching, Writer uses $ for the end-of-paragraph mark 
and \n for a line break. For a replacement character, use \n for 
the end-of-paragraph mark.

You don’t need to use Find & Replace (as you do in some other 
programs) to replace two end-of-paragraph marks (with nothing in 
between) with one. Instead, you can go to Tools > AutoCorrect > 
Options and check the box for Remove blank paragraphs.

Searches for end-of-paragraph marks are usually combined with 
other regular expressions and wildcards. The online help describes 
many regular expressions and their uses. Regular expressions can 
save you time and effort by combining multiple finds into one. Most 
of them are not the same in LibreOffice and Microsoft Office.

Checking spelling
The spelling feature of Writer can be used in two ways. You can use 
a toolbar icon to choose a method.

AutoSpellcheck checks each word as it is typed and displays a 
wavy red line under any misspelled words. When the word is 
corrected, the wavy red line disappears.

To perform a separate spelling check on the whole document or 
on selected text, click the Spelling and Grammar button or press F7. 
This opens the Spelling and Grammar dialog if any misspelled 
words are found.
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Here are some more features of the spelling checker:
• Right-click on a word with a wavy red underline to open a 

context menu. You can select from the suggested words, 
ignore the spelling, add it to the dictionary, or change the 
language used for the selection or paragraph.

Spelling context menu

• You can also change the dictionary language used (for 
example, Spanish, French, or German) on the Spelling and 
Grammar dialog.
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• To add a word to a dictionary, click Add in the Spelling and 
Grammar dialog and pick the dictionary to add it to.

• Click the Options button on the Spelling and Grammar dialog
to open a dialog similar to the one in Tools > Options > 
Language Settings > Writing Aids; see Chapter 2.

Checking grammar
If you have selected grammar checking, errors are shown underlined
by a wavy blue line. Right-clicking on this line brings up a context 
menu which may be similar to one of those shown below.

The first entry in the menu describes the suspected broken 
grammatical rule.

The second menu item in the left example is Explanations, which
opens your browser to a web page offering more information about 
the error. This entry is not always present in the context menu, as 
seen in the right example.

In the second section of the menu is the suggested correction. 
Clicking this changes the text to the suggestion.

In the third section of the menu you can choose to ignore the 
indicated error, or to open the Spelling and Grammar dialog.

Tip
The grammar checker is very good at finding certain types of 
errors. However, it is often wrong, especially when dealing with 
informal writing such as dialog in fiction. You’ll need to use 
some judgment regarding its suggestions.

52 Chapter 3  Write and edit



Additional grammar checking rules can be selected through  
Tools > Options > Language Settings > English sentence 
checking, as described in Chapter 2.

Using Writer’s built-in language tools
Writer provides some tools that make your work easier if you use 
more than one language in the same document or if you write 
documents in various languages.

On the Font tab of the Paragraph Styles dialog, you can specify 
that certain paragraphs be checked in a language that is different 
from the language of the rest of the document. See “Working with 
fonts” on page 86 for more information.

The main advantage of changing the language is that you can 
then use the correct dictionaries to check spelling and apply the 
localized versions of thesauruses, hyphenation rules, and 
AutoCorrect replacement tables.

You can also set the language for a paragraph or a group of 
characters as None. This option is especially useful when you insert
text such as web addresses or programming language snippets that 
you do not want to check for spelling.

Specifying the language in character and paragraph styles is the 
preferred method, because styles allow a greater level of control and 
make changing the language much faster.

However, you can set the language for the whole document, for 
individual paragraphs, or even for individual words and characters, 
all from Tools > Language on the menu bar.

For selection
Applies the selected language to the selected text (the selection 
can be as short as a few characters or as long as several 
paragraphs).

For paragraph
Applies the selected language to the paragraph where the cursor 
is located.

For all text
Applies the selected language to the entire document.
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Another way to change the language of a whole document is to 
use Tools > Options > Language Settings > Languages. In 
the Default languages for documents section, you can choose a 
different language for all of the text.

Unlike the menu tool that applies to the individual document, a 
change in the default language from the Options dialog is a general 
change of settings of LibreOffice and will therefore apply to all the 
documents created in the future. If you want to change the language 
for the current document only, be sure to select the For the 
current document only option.

The spelling checker works only for those languages in the list 
that show a check mark. If you do not see this symbol next to your 
preferred language, you can install the dictionary using Tools > 
Languages > More dictionaries online.

The language used for checking spelling is also shown in the 
status bar, next to the current page style (see page 22).

Using synonyms and the thesaurus
You can access a short list of synonyms from a context menu. Right-
click a word and point to Synonyms on the context menu. A 
submenu of alternative words and phrases is displayed. Click a word
or phrase in the submenu to have it replace the highlighted word or 
phrase in the document.
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The thesaurus gives a more extensive list of alternative words 
and phrases. Select the word or phrase you want to find more 
choices for, right-click, point to Synonyms in the content menu, 
then click Thesaurus from the Synonyms submenu.

Note
If the selected language does not have a thesaurus installed, this 
feature is disabled.

In the Thesaurus dialog, click a word or phrase in the list of 
meanings to select it. Click Replace to make the substitution.

For example, when given the word house, the thesaurus offers 
several meanings, including dwelling, legislature, sign of the 
zodiac, and others. Select a replacement word from the list under 
the relevant meaning, so for dwelling, you will see dwelling, home, 
domicile, abode, and other alternatives.
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Using automatic functions
Writer provides several ways to automate some of your work. If you 
do not want to use a particular automated function, you can turn it 
off easily.

AutoCorrect
Writer’s AutoCorrect function automatically corrects a long list of 
common misspellings and typing errors. For example, hte will be 
changed to the.

Select Tools > AutoCorrect > AutoCorrect Options to 
open the AutoCorrect dialog. There you can define what specific 
strings of text will be corrected. In most cases, the defaults are fine.

AutoCorrect is turned on when Writer is installed. To turn it off, 
uncheck Format > AutoFormat > While Typing.
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To fine-tune AutoCorrect, examine the different tabs of the 
dialog. You will see that many options are available.

To stop Writer from replacing a specific spelling, go to the 
Replace tab, highlight the word pair, and click Delete.

To add a new spelling to the list, type it into the Replace and 
With boxes on the Replace tab, and click New.

AutoCorrect can also be used as a quick way to insert special 
characters. For example, (c) will be autocorrected to ©. You can add
your own special characters.

Word completion
If Word Completion is enabled, Writer tries to guess which word 
you are typing and offers to complete this word for you. To accept 
the suggestion, press Enter. Otherwise, continue typing.

To turn off Word Completion, select Tools > AutoCorrect > 
AutoCorrect Options > Word Completion and uncheck 
Enable word completion.

You can customize word completion from the Word Completion 
tab.

• Add (append) a space automatically after an accepted word.
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• Show the suggested word as a tip that simply hovers over the 
word instead of completing the word as you type.

• Change the maximum number of words remembered for 
word completion and the minimum allowable length of the 
words.

• Delete specific entries from the word completion list.
• Change the key that accepts a suggested entry. The options 

are right arrow, End key, Return (Enter), Space bar, and 
Tab.

Automatic word completion occurs only after you type a word for
the second time in a document.

AutoText
You can assign text, tables, graphics, and other items to an AutoText
shortcut key combination. Then, to insert the AutoText, type the 
shortcut and press F3.

For example, rather than typing Senior Management, you can 
save those words as AutoText with the shortcut sm, then simply type
sm and press F3 to insert the words into your document. Similarly, 
you can save a formatted table as AutoText with the name tip and 
then insert a copy by typing tip and pressing F3.

To assign some text to an AutoText shortcut:

1 Type the text into your document.

2 Select the text.

3 Go to Tools > AutoText (or press Control+F3).

4 Type a name for your shortcut. Writer will suggest a one-
letter shortcut, which you can change.

5 Click the AutoText button on the right of the AutoText 
dialog and select New (text only) from the menu.

6 Click Close to return to your document.

Tip
If the only option under the AutoText button is Import, either 
you have not entered a name for your AutoText or there is no 
text selected in the document.
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Including document information
Sometimes you may want to put information such as the author, the 
file name, the date the document was last edited, or the word count 
somewhere in the text or in a header or footer.

Some information fields can be inserted directly from the Insert
> Field submenu.

Other information fields are on the Document or 
DocInformation tabs of the Fields dialog, shown below.

Select the type of information required in the left-hand column 
(here we have chosen Statistics), the specific item in the middle 
column, and the format in the right-hand column. If you’re not sure,
choose the default format selection (whatever is highlighted for your
choices in Type and Select). If the result is not what you want, you 
can change it later.
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Some of the document properties information is generated 
automatically, some comes from information you enter on the 
Description tab of the Document Properties dialog (File > 
Properties), and some comes from information on the User Data 
page of Tools > Options > LibreOffice (see page 30).
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4 Design your book using 
Writer’s styles

This chapter describes how to plan and set up the design of your 
book, using Writer’s styles. For information on the design choices 
you need to make, see Bruce Byfield’s book Designing with 
LibreOffice.

The steps in designing a book are:
• Plan the sequence of pages needed in the book.
• Set up the page styles needed for this sequence of pages.
• Set up the paragraph styles.
• Choose fonts, spacing, and other formatting details; see 

Chapters 5 and 6.

Tip
Some design choices (for example, headers and footers) for 
printed books are irrelevant to e-books. Other choices may need 
to be modified. 

What are styles? Why use them?
Styles are sets of formats for pages, text, frames, and other elements
of a document. When you apply a style, you apply a whole group of 
formats at the same time. Proper use of styles improves consistency 
in a document and makes major formatting changes easy.

To change the appearance of an element (such as the font), you 
change the style, and then all of the elements that use that style will 
change automatically. This helps maintain consistency throughout 
the book.

Writer also uses styles for processes such as compiling a table of 
contents.
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Tip
Any modifications of styles, and any new styles that you define, 
apply only to the document you are working on. If you want the 
changes to be available to other documents, you need to put 
them into a template. See Chapter 14 for details.

Types of styles
Writer has six types of styles:

• Page styles control page formatting (page size, margin, and 
the like).

• Paragraph styles control the formatting of entire paragraphs.
(Headings are a type of paragraph.)

• Character styles control the formatting of selected text inside
a paragraph.

• List styles control outlines, numbered lists, and bulleted lists.
• Frame styles control frames and graphics.
• Table styles control the appearance of tables of data.

The Styles deck in the sidebar lists all the styles defined for a 
document. 
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Basic page layout using page styles
All pages in a Writer document are based on page styles. Page styles 
define the basic layout of pages, such as page size, margins, the 
placement of headers and footers, borders and backgrounds, and 
number of columns. If you do not specify a page style, Writer uses 
its built-in Default page style.

You can modify Writer’s built-in page styles, and you can define 
new (custom) page styles. You can have one or many page styles in a
single document.

The illustration below shows a typical sequence of the pages in a 
book. Notice that some have no page numbers, while others have 
lower-case roman numerals (i, ii, iii) and others have Arabic 
numbers (1, 2, 3).
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Tip
The publishing term for all the pages before the first page of 
Chapter 1 (or the Part 1 page, if there is one) is front matter.

Automating the sequence of page styles
When you need a page with one style to be followed by a page with a
specific style, you can automate the sequence. The style of the page 
that follows can be the same as the style of the first page, or it can be
different.

As we’ll see in this section, automation is the only practical way 
to handle a sequence of page styles in some cases. In other cases, 
automation is optional but using it means you don’t have to 
remember which style comes next in the sequence and assign it 
manually.

The first thing to do is decide on the styles you need. Don't worry
if you think that later you might need another style or want to 
change the sequence—you can do so at any time.

The styles we’ll be using correspond to the pages shown in the 
diagram on page 63:

• Title (cover) page
• Copyright page
• Table of Contents page
• Other front matter pages
• First Page (for each chapter)
• Default page (for all other pages in each chapter)

Automating a sequence of styles makes use of the Next Style 
property of styles. You can define page styles in any order you want, 
but some ways are more efficient than others. You might think it 
makes sense to work through the page styles from the beginning of 
the book, starting with the Title page, but in fact it is easier to start 
at the end of a sequence of pages, so that the next style is always 
defined before it is needed in the sequence.

Single chapter
First we will look at a single chapter from somewhere in the book. 
Most chapters will be like this one. It needs two styles: First Page 
and Default. The figure on the next page shows the concept.
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Both of these styles are provided by Writer, so we don’t need to 
create new ones. In addition, both styles have been set up to have a 
Next Style of Default, so we can proceed without modifying them.

To demonstrate the effect of this automatic sequence:

1 Create a new document (choose File > New > Text 
Document or press Control+N). Make sure that end-of-
paragraph marks are showing.

2 Click anywhere in the first page of the document.

3 Go to Page Styles in the Styles deck of the sidebar and choose
First Page, or right-click in the Page Style area of the status 
bar and choose First Page from the pop-up list.

4 Type or paste something on this page. Because this is a 
demonstration of page styles, don’t be concerned with the 
formatting of the text. Keep typing or pasting until the text 
continues to a second page.

Notice that the page style for the new page is shown in the 
status bar as Default, which is the style that it should be. You
didn’t have to do anything; the change in page styles 
occurred automatically.

5 Keep typing or pasting until the text continues to a third 
page. Notice that the page style for the third page is also 
Default, as it should be.

Note
To apply the sequence of page styles to an existing chapter, all 
you would need to do is steps 2 and 3.
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Start of a book
The figure below shows a more complex sequence of page styles for 
the start of a book.

This sequence uses four styles that are not provided by Writer, 
so we need to create them. We’ll start at the end of the sequence and
work our way forward: Contents Other, Table of Contents, 
Copyright page, Title page.

1 Open a new document, or use the one from the previous 
example. Go to Page Styles in the Styles deck of the sidebar. 
Right-click and choose New from the pop-up menu.

2 On the Organizer tab of the Page Style dialog, type Contents
Other in the Name box. Open the Next Style drop-down list 
and select Contents Other.

3 For now, ignore the other tabs. Click OK to save.

4 Repeat steps 2, 3, and 4 three times, in this order:

Name: Table of Contents
Next Style: Contents Other

Name: Copyright page
Next Style: Table of Contents

Name: Title page
Next Style: Copyright page

To apply this sequence of styles, see Chapter 5.
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Add a chapter to the book sequence
How do you change from the “front matter” sequence to the chapter 
sequence? The concept is shown in the illustration on the next page.

A change from one sequence to a new sequence can be done 
either manually or by using a property of paragraph styles to 
automate the change. These methods are described in Chapter 5. 
Which method you use is entirely up to you.

Creating and modifying paragraph styles
Paragraph styles control aspects of a paragraph’s appearance such 
as text alignment, tab stops, line spacing, borders, and character 
formatting (font, font size, color). The formatting of individual 
words within a paragraph can be changed by using character styles 
or manual formatting. Character formatting is covered in Chapter 6.

Writer comes with many predefined paragraph styles, which you
can modify. You can also define new (custom) styles.

You can modify paragraph styles by:
• Using the Paragraph Style dialog
• Updating from a selection
• Using AutoUpdate (not recommended)
• Loading or copying styles from another document or 

template (not covered in this book)
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Properties of paragraph styles
You can save some time by understanding some of the properties of 
paragraph styles and then doing some things in a particular order. 
Two important properties are Inherit from and Next Style; both are 
found on the Organizer tab of the Paragraph Style dialog.

• Inherit from. When styles are linked, a change in the base 
style affects every style linked with it. For example, every 
Heading style (such as Heading 1, Heading 2) is linked with 
a base style called Heading.

• Next style. When you type a paragraph and then press 
Enter to start a new paragraph, the new paragraph will 
automatically have the style defined as the next style. For 
example, you can define the Heading 1 style to be followed by
a First paragraph style, the First paragraph style to be 
followed by a Text body style, and the Text body style to be 
followed by more paragraphs in the Text body style until you 
change one of them to another style.
The Next style property is effective only when you are typing 
in text. If you later apply a style (such as a heading) to a 
paragraph, the following paragraph does not change style.

Caution
If you are in the habit of manually overriding styles in your book,
be sure that the AutoUpdate option (on the Organizer page of 
the Paragraph Style dialog) is not enabled, or you will suddenly 
find whole sections of your document reformatting 
unexpectedly.

Modify the built-in sequence of styles
The built-in sequence of heading and paragraph styles uses 
Heading 1 for chapter titles and Heading 2, Heading 3, and so on 
for subheadings, with each heading followed by a paragraph in the 
Text body style. If you want a different sequence, read on. For our 
example sequence, we’ll modify three built-in styles (Heading 1, 
Heading 2, and Text body) and create one custom style 
(First para).
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Tip
Heading styles are essential for creating an automatic table of 
contents and for placing information such as chapter titles into 
headers or footers. For more information, see Chapters 5 and 10.

One common book design uses one paragraph style for the first 
paragraph of a chapter or section, and another paragraph style for 
all of the other paragraphs in the chapter or section. This book uses 
this design.

To set up a different style for the first paragraph of each chapter,
you need to do two things:

• Create a new style, or modify an existing style, for the first 
paragraph, and set it up to be followed automatically by the 
style used for the other paragraphs.

• Set up the heading styles to be followed automatically by your
chosen first paragraph style.

Because a style must exist before we can choose it as a Next 
Style, we will create the First paragraph style before defining the 
heading styles.

We want the First paragraph style to be the same as the Text 
body style, with one difference: Text body will have the first line 
indented, but First paragraph will have no indentation of the first 
line. We can save some time (and later inconsistencies if we change 
something else) by linking the First paragraph style to the Text 
body style and changing only that one setting. Later, if we make 
other changes to the Text body style, those changes (such as font 
and spacing) will apply to the First paragraph style as well.

Modify the Text body style
To do all of this efficiently, start with the Text body paragraph style.

1 On the Styles deck in the sidebar, go to the Paragraph Styles 
list. Right-click on the Text body style and select Modify 
from the pop-up menu.

2 On the Organizer tab, notice that you cannot change the 
name of the style (because it is a built-in style), the 
AutoUpdate option is not marked, Next Style is already set to
Text body, and the Text body style inherits from the Default 
style. All of these settings are what we want.
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3 On the Indents & Spacing tab, change the setting for First 
line (the example uses 18 pt).

4 Leave the other tabs alone for now. Click OK to save the 
change.

Create the First paragraph style
Now that we’ve modified the Text body style, we’ll create a First 
paragraph style linked with it.

1 On the Styles deck in the sidebar, right-click on the Text 
body style and select New.

2 On the Organizer tab, change the Name from Untitled to 
First paragraph. Do not select the AutoUpdate option.

3 Click on the Next Style list; it changes from Untitled to First 
paragraph. Scroll down and select Text body.

4 Notice the Inherit from setting, which is Text body. That is 
what we want, so leave it as shown.

5 Go to the Indents & Spacing tab and change the First line 
setting to 0.00. Leave the other tabs alone for now. 

6 Click OK to save the new style.
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Modify the heading styles

Now that we have created the First paragraph style, we can change 
the heading styles to use it as a next style. At the same time, we will 
set up the chapter titles (Heading 1) to start on a new page.

1 On the Styles deck in the sidebar, right-click the Heading 1 
style and select Modify.

2 On the Organizer tab, change Next Style to First paragraph.

3 On the Text Flow tab, under Breaks, select Insert and With 
Page Style. Choose First Page from the drop-down list of 
styles. Leave Page number set to 0. Click OK.

4 Repeat steps 1, 2, and 4 for the Heading 2 and Heading 3 
styles.

Modifying other paragraph properties
Paragraph styles define properties such as text alignment, tab stops,
line spacing, borders, typeface, font size, and color. You can create 
new styles, and modify the properties of existing styles, using the 
various tabs on the Paragraph Style dialog, or you can update from a
selection. You can also load styles from a template or other 
document.

New Style from Selection
To use this method, first change the formatting of a paragraph until 
it appears as you like. Then, go to the Styles deck in the sidebar and 
click the Styles actions icon on the upper right, then select New 
Style from the menu. The Create Style dialog opens. Type a name 
for the new style and click OK to save it.

Creating and modifying paragraph styles 71



Update Style
Change the formatting of a paragraph until it appears as you like. 
Then, click anywhere in the paragraph. In the sidebar Styles deck, 
click the style you want to update and then click the Styles actions
icon and select Update Style from the menu.

Load Styles (from a template or document)
The last option under the Styles actions icon is used to copy styles 
into the document from a template or another document.

Open the document to copy styles into. In the sidebar Styles 
deck, click the Styles actions icon and then Load Styles.

In the Load Styles dialog, find and select the template or 
document to copy styles from. Select the types of styles to be copied:
Text (Paragraph and Character styles), Frame, Pages, Numbering 
(List styles). If you select Overwrite, the styles being copied will 
replace any styles of the same names in the target document.

Click OK to copy the styles.
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5 Format pages

Apply your book design using Writer’s page styles.
• Define and apply page styles
• Set up headers and footers
• Set up page numbering

As you know, a book has different types of pages (copyright 
page, table of contents page, chapter title page, and so on). Writer 
controls the layout of these pages using page styles. Headers and 
footers are part of page layout, so they are included in the page style.

First define the appearance (format) of pages in the page styles. 
Then apply these page styles by using a combination of automatic 
sequencing and manually changing the sequence.

For advice on page formatting choices, see Designing with 
LibreOffice, by Bruce Byfield.

Defining page styles
In Chapter 4, we created the page styles for an example book and set
up their sequencing. Now we will define the margins and other 
formatting for the pages.

Examples

Default page style
The Default page style is the most commonly-used page style. In our
example, all the chapter pages (except the first page of each chapter)
use it. These pages are normally mirrored. Facing pages may have 
page numbers on the outer edges and the inner (binding) margin 
may be wider than the outer margin.

1 On the Page Styles tab of the Styles deck in the sidebar, right-
click on Default Style, and choose Modify.
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2 On the Page tab of the Page Style: Default Style dialog, in the 
Paper Format section, choose the page size for your book, or 
define a custom size by changing the dimensions in the 
Width and Height boxes. Choose Mirrored for the page 
layout. The Format item under Layout settings refers to 
the page numbers. For the Default Style pages, leave it set to 
1,2,3, ….

3 On the Header tab, choose Header on and uncheck Same 
content left/right. Leave the other settings unchanged.

4 The Footer tab is almost identical to the Header tab. Choose 
Footer on and uncheck Same content left/right. Leave 
the other settings unchanged.

5 Click OK to save your changes.

You can also define some formatting of the headers and footers here
(for example drawing a line above the footer). See page 154 for more
information.
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First Page style
The first page of a chapter normally starts on a right-hand page. It 
usually does not have a header, but it may have a footer containing a
page number.

1 On the Page Styles tab of the Styles and Formatting window, 
right-click on First Page and choose Modify.

2 On the Page tab of the Page Style: First Page dialog, set the 
Paper Format to match the paper format chosen for the 
Default page style.

3 Set Page layout to Only right and set the margins as 
needed. Typically the right margin for the First Page style is 
the same as the outer margin for the Default page style, the 
left margin is the same as the inner margin, and the bottom 
margins are the same. You may want to make the top margin 
larger.

4 On the Header tab, make sure Header on is not checked.

5 On the Footer tab, choose Footer on. Leave the other 
settings unchanged.
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Title Page style
A title page is always a right-hand page. It usually has no header or 
footer.

1 On the Page Styles tab of the Styles deck in the sidebar, right-
click on Title Page and choose Modify.

2 On the Page tab of the Page Style: Title Page dialog, set the 
Paper Format to match the paper format chosen for the 
Default page style.

3 Set Page layout to Only right and set the margins as 
needed. The margins for a title page are often quite different 
from the margins for other pages in a book.

4 On the Header and Footer tabs, make sure Header on and 
Footer On are not selected.

Copyright page style
A copyright page is always a left-hand page. It has no header or 
footer and may have margins that are different from other pages in 
the book.

1 On the Page Styles tab of the Styles deck in the sidebar, right-
click on Copyright and choose Modify.
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2 On the Page tab, set the Paper Format to match the paper 
format chosen for the Default page style. Set Page layout to 
Only left and set the margins as needed.

3 On the Header and Footer tabs, make sure Header on and 
Footer On are not selected.

Table of Contents page style
The Table of Contents page style is usually similar to the First Page 
style for chapters, but it may have one major difference: the page 
numbers are often in lower-case Roman numerals.

1 On the Page Styles tab of the Styles deck in the sidebar, right-
click on Table of ontents and choose Modify.

2 Define the Contents page style to match the First Page style 
except for Format in the Layout settings section of the Page 
tab: choose i, ii, iii, … from the drop-down list.

3 On the Header tab, make sure Header on is not selected. 
On the Footer tab, select Footer on. Leave the other 
settings unchanged.
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Contents Other page style
This page style is similar to the Default page style, but the page 
numbers are in lower-case Roman numerals.

1 On the Page Styles tab of the Styles deck in the sidebar, right-
click on Contents Other and choose Modify.

2 Make all the settings the same as for the Default page style 
except for Format in the Layout settings section: choose 
i, ii, iii, … from the drop-down list.

3 On the Header and Footer tabs, make the settings the same 
as for the Default page style.

Setting up headers and footers
Headers and footers are specified in page styles. Placing text (or 
fields such as page numbers or the name of the chapter) in a header 
or footer causes that text to appear on all pages with that page style 
and change to suit the page it’s on.

Note
Many people incorrectly use the words header and heading 
interchangeably, but the two words refer to quite different 
concepts. Headers are sometimes called running headers.

Our basic page layout included some headers and footers. Now we’ll 
see how to use them.
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Headers and footers usually have only one paragraph. You can 
also design more complex headers and footers, and you can include 
graphics. We’ll look at the simple case here. See page 154 for 
information on more complex layouts.

Numbering pages
The simplest case is to have the page number at the top or bottom of
every page. To do this, click in the header or footer and select 
Insert > Page Number from the menu bar.

The page number now appears on every page that has this page 
style. You can align the page number to the left, right, or center of 
the page.

Note
Page numbers appear with a gray background. This background 
indicates that the page number is a field. It is not printed and is 
not visible in a PDF. To turn this feature on or off, choose View 
> Field Shadings (or press Ctrl+F8), but be aware that turning
field shadings off affects all fields in the file.

Tip
If you see the words Page number instead of a number in the 
header or footer, click on View > Field Names (press Ctrl+F9)
to deselect it and display the page numbers.

Applying page styles
To format a book, use a combination of automatic sequencing of 
page styles and manually changing the sequence.

Apply a sequence of page styles
Your book file has a title page, a copyright page, one or more table of
contents pages, and more than one chapter. The copyright page, 
first page of the table of contents, and first page of each chapter 
were created using manual page breaks.

The sequence of page styles was set up Chapter 4. Now we will 
apply these styles.

1 In the Styles deck in the sidebar, click the Page Styles icon.
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2 With the cursor in the title page of the document, choose 
Title page in the Styles deck.

3 Go to the second page of the book. The status bar at the 
bottom of the Writer window should show Copyright as the 
page style.

4 Go to the third page. The status bar should show Table of 
Contents as the page style.

5 Go to the next page. The status bar should show Contents 
Other as the page style.

At this point, all the pages that follow have a page style of Contents 
Other. Now you need to change the page style of the first page of 
each chapter, as described below.

Restart page numbering
You may want to restart the page numbering at 1 on the first page of 
the first chapter, for example if you want the table of contents to be 
numbered with Roman numerals and the main body of the 
document numbered in Arabic numerals.

1 Go to the first page of Chapter 1.

2 Click in the first paragraph on the page—usually the chapter 
title—and choose Format > Paragraph from the menu 
bar, or right-click and choose Paragraph > Paragraph 
from the pop-up menu.

3 On the Text Flow tab of the Paragraph dialog, under Breaks, 
select Insert and With Page Style. First Page should be 
selected in the drop-down list of styles.
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4 Select the check box next to Page number and choose 1, 
then click OK.

Now the status bar for this page shows First Page as the 
style. Go to the next page. The status bar should show 
Default.

5 At this point, all the pages that follow should have a page 
style of Default, with the exception of the first page of each 
chapter. If you have set up the Heading 1 paragraph style as 
described in Chapter 4, these should have a page style of 
First Page.

6 Go to the first page of each chapter and verify that its page 
style is First Page. If it is not, repeat steps 2 and 3, but leave 
Page number set to 0 for all chapters except the first, so 
the page numbers continue from one chapter to the next for 
the entire book.

Add a title page to an existing book
If your book does not include a title page, you can add one any time.

1 Place the cursor before the first character on the first page of 
the file.

2 Choose Insert > Manual Break from the menu bar. On 
the Insert Break dialog, choose Page Break, ignore the 
other boxes, and click OK.

3 Go to the new (blank) first page and set its page style to Title 
Page. Type or paste in the text for the title page.

Writer also provides another way to add a title page (Format > 
Title Page from menu bar).

Add a copyright page to an existing book
If the book has a title page but no copyright page, you can add one.

1 Be sure end-of-paragraph markers are showing.

2 With the cursor after the last character in the last paragraph 
of the title page, choose Insert > Manual Break from the 
menu bar.

3 On the Insert Break dialog, choose Page Break, ignore the 
other boxes, and click OK.
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The document now has a second page, with a page style of 
Copyright.

In a similar way, you can add pages for the table of contents, a 
foreword, a dedication, and so on.

Use the Page deck in the sidebar
You can change some page style settings using the Page deck in the 
sidebar, for example the page layout and page numbering styles, and
turn the header and footer on or off.

Caution
Any change made to a page is stored in its page style and will 
change all pages that use that style. If you want to change the 
formatting of just one page, you may need to create a new page 
style.
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6 Format text

This chapter covers the basics of formatting text in Writer:
• Typography
• Hyphenating words
• Working with fonts
• Applying paragraph styles
• Applying character styles
• Inserting special characters and dashes
• Defining tabs and indents
• Working with lists

More advanced text formatting techniques are described in 
Chapter 12.

Typography
To create a professional appearance for your book, follow a few 
simple typographic principles.

• Choose a typeface (font) and size that is easy to read and 
prints well (some typefaces are too light or too heavy).  For 
help in choosing a typeface, see Designing with LibreOffice, 
by Bruce Byfield, or one of the many other books and 
websites on this topic.

• Use “curly quotes” (whether single or double quotation 
marks) and apostrophes—not "straight quotes". But don’t use
curly quotes for symbols such as foot and inch—these are 
correctly done as straight quotes.
To use curly quotes, go to Tools > AutoCorrect > 
AutoCorrect Options > Localized Options and select 
the Replace option for both single and double quotes.

• Be sure your curly quotes are the right way around. Many 
programs, including Writer, sometimes get this wrong.
For example, the apostrophe in the phrase in the ’90s 
sometimes turns into an opening single quotation mark (‘). 
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To fix this, type two apostrophes and delete the first one, 
which is the one that turns in the wrong direction.

• Use real dashes, not two or three hyphens. See “Inserting 
dashes” on page 91.

• Use the correct symbols for copyright (©), registered 
trademark (®), degrees (°), multiplication signs (×, not an 
ordinary x), certain fractions, and other special symbols.
You can use either AutoCorrect or Insert > Special 
Character for this, depending on the symbol.

• Decide whether to use fully-justified or left-aligned (ragged-
right) paragraphs. Many people think “real books” must use 
fully-justified text, but left-aligned text is becoming more 
commonly used, including in books from big-name 
publishers. Full justification in Writer, as in most word 
processors, often does not produce high-quality results. To 
make it look right, you would have to make some manual 
adjustments, not discussed in this book.

• Decide whether to hyphenate words at the ends of lines of 
type. If you use fully-justified paragraphs, the word spacing 
may look awkward if words are not hyphenated, but the 
hyphenation dictionaries in software like Writer are often 
incorrect, so you may need to do a lot of manual adjustment 
to achieve a professional-looking result.

Hyphenating words
You have several choices regarding hyphenation: let Writer do it 
automatically (using its hyphenation dictionaries), insert 
conditional hyphens manually where necessary, or don’t hyphenate 
at all. Each choice has its pros and cons. I prefer to insert 
conditional hyphens manually when using fully-justified 
paragraphs, and I prefer no hyphenation when using left-aligned 
(ragged-right) paragraphs, as in this book.

If you let Writer hyphenate words automatically, you’ll need to 
check carefully for incorrect hyphenation and make corrections 
when proofreading your book.

To turn automatic hyphenation of words on or off:

1 On the Paragraph Styles page of the Styles deck in the 
sidebar, right-click on Default Style and select Modify.
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2 On the Paragraph Style dialog, select the Text Flow tab.

3 Under Hyphenation, select or deselect the Automatically 
option.

4 Click OK to save.

Note
Turning on hyphenation for the Default paragraph style will 
apply it to all other paragraph styles that are based on Default. 
You can individually change other styles so that hyphenation is 
not active. Any styles that are not based on Default are not 
affected and must be set separately if you want them hyphenated
as well.

You can also set some hyphenation choices through Tools > 
Options > Language Settings > Writing Aids. In Options, near
the bottom of the dialog, scroll down to find the hyphenation 
settings.

To change the minimum number of characters for hyphenation, 
the minimum number of characters before a line break, or the 
minimum number of characters after a line break, select the item, 
and then click Edit.

Hyphenate without inquiry specifies that you will never be 
asked to manually hyphenate words that the hyphenation dictionary

Hyphenating words 85



does not recognize. If this box is not selected, when a word is not 
recognized, a dialog opens and you can manually enter hyphens.

Hyphenate special regions specifies that hyphenation will 
also be carried out in footnotes, headers, and footers.

Hyphenation options set on the Writing Aids dialog are effective 
only if hyphenation is turned on through paragraph styles.

Choices on the Writing Aids dialog for Characters before line 
break and Characters after line break override paragraph style 
settings for Characters at line end and Characters at line begin.

Manual hyphenation
To manually hyphenate words, do not use a normal hyphen, which 
will remain visible even if the word is no longer at the end of a line 
when you add or delete text or change margins or font size. Instead, 
use a conditional hyphen, which is visible only when required.

To insert a conditional hyphen inside a word, click where you 
want the hyphen to appear and press Control+hyphen. The word 
will be hyphenated at this position when it is at the end of the line, 
even if automatic hyphenation for this paragraph is switched off. 
You can also use Insert > Formatting Mark > Insert Soft 
Hyphen from the menu bar.

Working with fonts
Fonts are handled through both paragraph styles and character 
styles. Paragraph styles define the font characteristics for the entire 
paragraph. When you apply a character style to selected text within 
a paragraph, the character style over-rides the paragraph style for 
that bit of text.

You can apply many formats (including font choices and type 
sizes) to paragraphs and characters using the buttons on the 
Formatting toolbar. However, it is highly recommended that you 
use styles and not manual formatting, especially for books and other
long documents. As stated in Chapter 4, using styles is usually better
and more convenient in the long run. For this reason, this book does
not cover manual formatting.
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Use paragraph styles
The Paragraph Style dialog has three tabs that have to do with fonts.
Other tabs are described in “Creating and modifying paragraph 
styles” starting on page 67.

Font
Sets the font, typeface, and size. You can set the size in several 
ways, including as a percentage of the font size defined for the 
paragraph style that this style is based on. For example, you 
might set a heading to be 130% of the body text size. If you later 
make body text larger or smaller, the heading adjusts to match. 
You can also set the language of the paragraph, so that spelling 
will be checked using the correct dictionary.

Font Effects
Sets font color, underlining, relief, and other effects.

Position
Sets text rotation and character spacing for the paragraph style. 
See Chapter 12 for some examples of use. Subscript and 
superscript are more likely to be used in character styles.

Use character styles
Character styles complement paragraph styles and are applied to 
groups of characters instead of whole paragraphs. They are used 
when you want to change the appearance or attributes of only parts 
of a paragraph, such as a word or phrase. Some effects that can be 
obtained by means of character styles are bold or italic typeface, 
subscripts, or a change in font.

Character styles do not have as many options as paragraph 
styles, but the Font, Font Effects, and Position tabs are similar. See 
Chapter 12 for some examples of use.

If you are accustomed to formatting text manually, character 
styles can take some getting used to. Here are some suggestions for 
making the transition easier:

• Never mix character styles and manual formatting. Manual 
formatting supersedes character styles. If you combine the 
two, you may end up wasting hours trying to figure out why 
your character styles don’t work.
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• Right-clicking and choosing Clear Direct Formatting 
removes any text formatting (both manual and styles).

• Keep the Styles deck open in the sidebar to make paragraph 
and character styles easy to access.

Applying paragraph and character styles
Writer provides several ways for you to apply styles to paragraphs 
and characters:

• Using the Styles deck in the sidebar
• Using the Set Paragraph Style list
• Using Fill Format mode
• Using keyboard shortcuts

To apply a paragraph style, click anywhere in the paragraph, and
then use one of these methods. To apply a character style, select the 
text to be formatted, and then use one of these methods.

Use the Styles deck in the sidebar
Click anywhere in the paragraph, or select the text to be formatted, 
and then double-click on the name of the style in the Styles deck.

Tip
At the bottom of the Styles deck is a drop-down list, as shown in 
the example on page 62. You can choose to show all styles, only 
custom styles, or other groups of styles.

Use the Set Paragraph Style list
After you have used a paragraph style at least once in a document, 
the style name appears in the Set Paragraph Style list on the left of 
the Formatting toolbar.

Click in the paragraph you want to apply a style to, then open 
this list using the down-arrow to the right, scroll through the list 
and click on the style to apply it.

Tip
Select More... at the bottom of the list to open the Styles deck in
the sidebar.
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Use Fill Format mode
Use Fill Format to apply a style to many different areas quickly 
without having to go back to the Styles deck or the Apply Style list 
every time.

1 Open the Styles deck in the sidebar and select the style you 
want to apply.

2 Click the Fill Format Mode icon. The mouse pointer 
changes to a pouring-can icon.

3 To apply a paragraph style to a paragraph, click on the 
paragraph.

To apply a character style, hold down the mouse button while
selecting the characters; when you release the mouse button, 
the style is applied. You can also click on a word to apply the 
selected character style to that word.

4 Repeat step 3 until you have made all the changes you want 
using that style.

5 To quit Fill Format mode, click the Fill Format Mode icon 
again or press the Esc key.

Caution
When this mode is active, a right-click anywhere in the 
document undoes the last Fill Format action. Be careful not to 
accidentally right-click and thus undo actions that you want to 
keep.
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Use keyboard shortcuts
Some keyboard shortcuts for applying paragraph styles are 
predefined, including Ctrl+0 for Text body, Ctrl+1 for Heading 1, 
and Ctrl+2 for Heading 2. You can modify these shortcuts and 
create your own (see Chapter 15).

Inserting special characters
A special character is one that is not on a standard English 
keyboard. For example, © ¾ æ ç ñ ö ø ¢ are all special characters. 
To insert a special character:

1 Click where you want the character to appear.

2 Choose Insert > Special Character to open the Special 
Characters dialog.

3 Select the characters (from any font or mixture of fonts) you 
wish to insert, in order; click Insert after each one. The 
selected character is shown in the upper right of the dialog.

Note
Different fonts have different special characters. If you do not 
find a particular special character you want, try a different font.
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Inserting non-breaking spaces and hyphens
To keep two words from being separated at the end of a line, press 
Control+spacebar after the first word (instead of just the spacebar) 
to insert a non-breaking space.

In cases where you do not want a hyphen to appear at the end of 
a line, for example in a telephone number such as 123-4567, press 
Shift+Control+hyphen to insert a non-breaking hyphen. These 
show with a gray background on screen.

You can also use the Format > Formatting Mark menu.

Inserting dashes
An em dash (—) is the length of the character m; an en dash (–) is 
the length of the character n. En and em dashes are used for 
different purposes in typography. (The Wikipedia page on dashes 
has a good summary.)

You can enter en and em dashes in several ways.
If you have selected the Replace dashes option under Tools > 

AutoCorrect > Options, then when you type two hyphens, they 
are replaced with a dash. The type of dash depends on whether you 
also type spaces before or after the hyphens. In the following table, 
the A and B represent text consisting of letters A to Z (in upper or 
lower case) or digits 0 to 9.

Text that you type Result
A - B (A, space, hyphen, space, B) A – B (A, space, en-dash, space, B)
A -- B (A, space, hyphen, hyphen, space, 
B)

A – B (A, space, en-dash, space, B)

A--B (A, hyphen, hyphen, B) A—B (A, em-dash, B)
A-B (A, hyphen, B) A-B (unchanged)
A -B (A, space, hyphen, B) A -B (unchanged)
A --B (A, space, hyphen, hyphen, B) A –B (A, space, en-dash, B)
1--2 (number, hyphen, hyphen, number) 1–2 (number, en dash, number)
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You can also use the Insert > Special Characters dialog; 
select the U+2013 or U+2014 character.

A third method uses keyboard shortcuts. These shortcuts vary 
according to your operating system and are not covered here

Tip
You can also record macros to insert en and em dashes and then 
assign those macros to unused key combinations, for example 
Ctrl+Shift+N and Ctrl+Shift+M. See Chapter 15.

Defining your own tabs and indents
The default tab stop interval (defined in Tools > Options > 
LibreOffice Writer > General) controls two things: tabs within 
paragraphs and the indentation of entire paragraphs when using the
Increase Indent button on the Formatting toolbar.

Using the default tab stops to space out or indent material on a 
page is not recommended.

• If you use the default tab interval and then send the 
document to an editor who uses a different default tab 
interval, then your tabbed material will be displayed using the
other person’s default tab settings.

• Any changes to the default tab stops will change the existing 
default tab stops in any document you open afterward, as well
as tab stops you insert after making the change.

To avoid these unwanted changes, define your own tab stops in 
paragraph styles or individual paragraphs, using the Tabs page of 
the Paragraph or Paragraph Style dialog. Better still, use a table to 
position text.

To change the indentation of one or more selected paragraphs, 
use the Indents & Spacing page of the Paragraph dialog.  You can 
also change the indentation defined in the paragraph style. Right-
click on the paragraph, choose Edit Style from the pop-up menu, 
and go to the Indents & Spacing page.

Working with lists
List styles (also called numbering styles) work together with 
paragraph styles. They define indentation, alignment, and the 
numbering or bullet characters used for list items. You can define 
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many list styles, from simple bulleted lists to complex multi-level 
(nested) lists.

Although you can create simple lists quickly by using the Toggle 
Numbered List or Toggle Bulleted List icons on the Formatting 
toolbar, and create quite complex nested lists using the icons on the 
Bullets and Numbering toolbar, the appearance of the resulting lists 
may not be what you want. And if you later need to change the 
appearance of the lists, you will have a lot of manual work. Using 
List styles is usually better and more convenient in the long run.

Note
Writer uses two terms, numbering style and list style, for the 
same thing. For example, the tooltip in the Styles deck of the 
sidebar says List Styles, but its style dialog is Numbering Style.

Create a new list style
The dialog that creates a new list style consists of six tabs, in 
addition to the usual Organizer tab.

Bullets, Numbering Style, and Image tabs
The Bullets, Numbering Style, and Image tabs contain predefined 
formatting for list item symbols (bullets or numbers). To use one of 
them for your style, click on the image. A thick border indicates that 
you have selected the item.

The bullets on the Bullets tab are font characters; those on the 
Image tab are graphics.

Outline tab
Use the Outline tab to select from eight predefined nested lists. (A 
nested list is one that is embedded in another list. For example, on 
page 97 the list numbered a-b-c is nested within the list numbered 
1-2-3-4. Nested lists can be several levels deep.)

You can also select a predefined list and use it as a starting point 
for your own style, customizing the list using the Position tab and 
the Customize tab.
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Position tab
Use the Position tab to fine tune the indentation and spacing of the 
list item symbol and the text of the list item. Use this tab together 
with the Customize tab (next section).

You can adjust these settings for each level individually or all at 
once (to make them all the same). I recommend adjusting the 
settings in the order given below and not according to the order on 
the dialog. Start from the overall indentation for the list elements, 
then fix the position of the symbols, and finally adjust the alignment
of the symbols.

• Numbering followed by: the element that comes right 
after the bullet or number (plus any characters—for example, 
a punctuation mark—chosen on the Options tab to appear 
after the number). Choose between a tab stop, a space, or 
nothing. If you select the tab stop, you can specify the 
position of the tab.

• Indent at: how much space is reserved for the numbering 
symbol, measured from the left page margin. The alignment 
of the first line of the list is also affected by any tab you may 
have set to follow the numbering.

• Aligned at: the position of the numbering symbol, measured
from the left margin of the page.

• Numbering alignment: how the numbering (including any
text before or after as set in the Options page) will be aligned.
Select from the drop-down menu. The Aligned at value 
determines the symbol alignment.
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Tip
To fully appreciate how numbering alignment works, try to 
create a numbered list with more than ten elements and make 
sure that enough room has been made for a number of two or 
more digits.

A numbered list of CD tracks highlighting the various elements

Customize tab
Use the Customize tab to define the style of the outline levels.

First, on the left side, select the outline level that you want to 
modify. To modify all ten levels at once, select 1 – 10 as the level. If 
you started from a predefined outline, some of the levels will already
have settings.

Your choice of numbering style in the Numbering list (bullet, 
graphics, or one of the numbering sequences such as 1, 2, 3, ...) 
determines which other options are available. The right-hand side of
the dialog shows a preview of the modifications made.

To revert to the default values, click the Reset button in the 
bottom right corner.
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Apply the list style
Now that the list style is available, it can be applied quickly to any 
list in the document. Select the list and then double-click on the 
desired list style name in the Styles and Formatting window.

Remember that applying a list style does not affect the 
characteristics of the underlying paragraph; therefore you may want
to make sure that you are satisfied with the paragraph style before 
applying the list style.

If you have more than one list in a document, the second and 
subsequent lists with the same style continue their numbering from 
the previous list. To restart a list at 1, right-click anywhere in the 
paragraph you want numbered 1, and choose Restart numbering.

To stop using numbering, click the Numbering On/Off icon 
on the Standard toolbar.

Tip
If you intend to combine several files into one book, be sure to 
restart list numbering for the first list in every chapter. If you 
don’t, then when you combine the files, the first list will continue
numbering from the last list in the previous chapter.
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Combine list and paragraph styles
When applying a list style, the underlying paragraph style remains 
unchanged. If your list must also have a certain font size, certain 
indentations, and so on, you can combine a specific list style with a 
paragraph style and then apply the paragraph style to the list.

To combine a list style with a paragraph style, use the 
Numbering page of the Paragraph Style dialog.

1 Create the list style that you want to use for the paragraph, 
for example MyNumberingStyle.

2 Create a new paragraph style.

3 On the Organizer tab of the Paragraph Style dialog:

a Give the new paragraph style a name, say Numbered 
Paragraph.

b For Next style, choose Numbered Paragraph (this will
make the following paragraph have the same style, until 
you choose a different style).

c For Inherit from, choose None.

4 Set up this paragraph style to your liking. Because the 
indentation is controlled by the list style, do not change the 
indent settings on the Indents & Spacing tab. (You might 
want to change the spacing above and below the paragraph.)

5 On the Outline & Numbering tab, choose the 
MyNumberingStyle style created in Step 1.

6 Click OK to save this style.
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7 Create PDFs and covers

Writer can export documents to PDF (Portable Document Format), 
the file format usually required by print-on-demand publishers. 
PDF is also used for some ebooks.

Be sure to check with your print-on-demand service for any 
special requirements they may have regarding PDFs. At the time of 
writing, common requirements include:

• Graphics must not have transparency. If necessary, use your 
image processing program to remove the transparency. 
(Consult that program’s documentation for how to do this.)

• Graphics/images should be at a resolution of no more than 
600 dpi (300 dpi is often preferred). You can set this during 
PDF export.

• All fonts must be fully embedded. Writer’s PDF export does 
this automatically.

• For printed books, do not include the front or back cover in 
the file with the interior pages. (You’ll need a separate file for 
the cover, probably in a graphic format, not PDF.) For a PDF 
ebook, you probably want to include at least the front cover 
image in the file with the interior pages.

The best settings for PDFs intended for printing may be different
from the best settings for PDFs to be read on-screen. If you want to 
make your book available in both print form and as a downloadable 
PDF, you may want to create two PDFs using different settings.

Quick export to PDF
Click the Export Directly as PDF icon to export the entire 
document using the last set of selections made through the PDF 
Options dialog. You can choose the file name and location for the 
PDF, but you do not get a chance to choose a page range or the print
quality. Direct export is convenient for creating draft PDFs or 
multiple PDFs using the same settings.
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When producing a PDF to send to your printing service, be sure 
to go through the PDF Options dialog to ensure that all the settings 
are exactly what you want.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, 
use File > Export As > Export as PDF. The PDF Options dialog 
has six pages (General, Initial View, User Interface, Links, Security, 
and Digital Signatures). Make your selections, and then click 
Export. Then you are asked to to choose the location and file name 
of the PDF to be created, and click Export.

General tab of PDF Options dialog
On the General tab, you can choose which pages to include in the 
PDF, the type of compression to use for images (which affects the 
quality of images in the PDF), and other options.
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Range section

All
Exports the entire document. This is the setting you would 
normally use for creating a PDF of a book.

Pages
As you assemble the book, you might want to export a few 
sample pages. For a range of pages, use the format 3–6 (pages 3 
to 6); for single pages, use 7,9,11 (pages 7, 9, and 11). You can 
also export a combination of page ranges and single pages, by 
using a format like 3–6,8,10,12.

Selection
Exports whatever material is selected. Useful for checking 
portions of a book.

Images section

Lossless compression
Images are exported without any loss of quality. For printed 
books, select this option.

JPEG compression
Allows for varying degrees of quality. A setting of 90% tends to 
work well with photographs. Suitable for PDF ebooks.

Reduce image resolution
For print-on-demand publishing, set this for 300 or 600 dpi 
(dots per inch). Lower-dpi images may be suitable for ebooks if 
image quality is not a major concern, but they are not suitable 
for printed books. Higher dpi images are best for commercial 
offset printing, but may be rejected by print-on-demand 
services. Check with your printing service to be sure.

Watermark section
When the Sign with Watermark option is selected, a transparent 
overlay of the watermark text you specify appears on each page of 
the PDF. You might use this to print “Draft” or “Not for Resale” or 
other words on copies of your book that you send out for review.

Controlling PDF content and quality 101



General section

Hybrid PDF (embed ODF file)
Choose this setting to export the document as a file containing 
two file formats: PDF and ODF. In PDF viewers it behaves like a 
normal PDF file, but it remains fully editable in LibreOffice. 
Note that this choice can significantly increase the size of the 
exported file. Do not select this option for printing.

Archive PDF/A-1a
This format is designed for long term preservation. It is not 
suitable for print-on-demand printing. Do not select.

Tagged PDF
Relevant only for onscreen viewing of PDFs. Depends upon the 
ODT file having special tags embedded within it. This topic is too
complex for this book. Do not select.

Create PDF form
Choose format of forms submitted from within the PDF file. Not 
relevant to print-on-demand or e-books. Do not select.

Export bookmarks
Creates PDF bookmarks for all hyperlinked table of contents 
entries. For printed books, do not select. For PDF ebooks, select 
this option.

Export comments
Exports comments as PDF notes. Do not select.

Export automatically inserted blank pages
Books usually have chapters set to always start on an odd-
numbered (right-hand) page. When the previous chapter ends 
on an odd page, Writer inserts a blank page between the two odd
pages. For printed books, select this option. For ebooks, you may
wish to deselect this option.

View PDF after export
Your default PDF viewer will open and display the newly 
exported PDF immediately after it is generated. This option is 
handy for reminding you to check the PDF for errors.
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Initial View tab
This tab is relevant only for ebooks. The options control how a PDF 
viewer displays the file; see page 105.

To avoid problems for printed books, choose Page only in the 
Panes section, leave Open on page as 1, and choose Default for 
Magnification and Page layout.

User Interface tab
This tab is relevant only for ebooks. The options control how a PDF 
viewer displays the file.

To avoid problems for printed books, deselect all options except 
All bookmark levels in the Bookmarks section.

For ebooks, see page 105.

Tip
Be sure the correct title is on the Description tab of the 
Document Properties (File > Properties).
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Links tab
Chooses how links between ebooks and other electronic documents 
are exported to PDF, an advanced topic that is not covered in this 
book.

For printed books, deselect all options, except Default mode in
the Cross-document links section.

Security tab
For PDFs that are to be printed, do not set any passwords. Printers 
cannot handle files that require passwords. For an ebook, you may 
wish to set some of these passwords; see page 105. 
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Digital Signatures tab
Digital signatures are used to ensure that the PDF was really created
by the original author (that is, you), and that the document has not 
been modified since it was signed. Do not use this page when 
creating PDFs for print-on-demand publishing or distribution for 
onscreen reading.

Creating a PDF for onscreen reading
A PDF can be distributed as an ebook. The format is a good choice 
when page layout is important. PDFs can be read on almost any 
device, although they may be difficult to read on a small screen such 
as a smartphone because the size of pages and text is fixed.

PDFs, like other ebook formats, can include color without 
increasing the cost of production. LibreOffice user guides are 
provided in downloadable PDF as well as sold as printed books.

Required settings, and some optional settings, vary between 
PDFs intended for printing and PDFs intended for distribution as 
ebooks. This section describes some settings suitable for ebooks.

General page
Select Export bookmarks. You may wish to deselect Export 
automatically inserted blank pages.
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Initial view page
Select Page only in the Panes section and Default in the Page 
Layout and Magnification sections.

User Interface page
Select Display document title in the Window Options section
and leave all User Interface Options unselected. In Bookmarks, 
select All bookmark levels, select Visible bookmark levels
and change the number to match the number of heading levels 
in the table of contents of the printed book.

Most of the choices on this page are useful mainly for PDFs to be
used in a presentation or a kiosk-type display.

Links page
The choices in the General section are more advanced than most 
books require; I recommend you leave them unselected. In the 
Cross-document Links section, choose Default mode.

Security page
Here you can set passwords to open the book or perform some 
actions on the book, such as whether readers can print, edit, 
copy, or comment on the book, extract pages, or make any other 
changes. I recommend that you don’t set a password to open the 
file, but you might want to set some permissions.

Creating covers for print books
The title, subtitle (if any), and author name must be present on the 
front cover of your book and must match the metadata you provide 
for the book, or it will not be accepted for distribution. (Check File 
> Properties for metadata such as Title and Author.)

You can create covers in LibreOffice Draw or in a program such 
as GIMP or Inkscape. Be sure to save (or export) the cover to a 
format such as PNG, JPG, or GIF, with a suitable resolution of at 
least 300 dots per inch (dpi). Check with your printer or publishing 
service to see if they require a higher resolution.

For a print book, do not include the cover in the file with the 
interior pages. For a PDF to be distributed as an ebook, you may 
wish to embed the front cover image on the first page of the file.

106 Chapter 7  Create PDFs and covers



8 Create ebooks

After you finish writing and formatting your book, you can create an
ebook in two ways:

• Export to the EPUB format directly from Writer. If you want 
a different or additional format (such as MOBI for Kindle), 
you may prefer the second method.

• Open the ODT (Writer) file in Calibre (recommended) and 
export to an ebook format (EPUB or other) from there.

Which option you choose depends on how complicated the 
formatting is and what ebook formats you require. Be prepared to 
experiment to get the results you need.

Before you begin, check whether your online publishing service 
requires specific settings, such as the EPUB version. It may not 
allow a table of contents other than one created within the ebook 
itself; if you, you’ll need to remove the TOC from your ODT file. You 
may also wish to remove any blank pages from the ODT file. Lastly, 
gather any other information and files you may need, such as the 
cover image, the ISBN, and other metadata such as keywords.

Tip
Your online publishing service may do the ebook conversion for 
you. You might try it first, to see if the result is acceptable. If the 
conversion fails, the service may give you enough information to 
help you correct any problems.

Creating an ebook cover
An ebook cover is sometimes called a marketing image. It is 
provided as a separate PNG or JPG file separate from the interior 
text and may also be embedded in the interior file.

Check your publishing service for any specific requirements. For 
example, the title and author name in cover art must match the title 
and author name provided in metadata and on the book’s cover 
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page. You cannot reuse an ISBN from another book, including the 
print edition of the same title.

You can create the cover in LibreOffice Draw or in a program 
such as GIMP or Inkscape. Be sure to save (or export) the cover to a 
format such as PNG or JPG.

Exporting to EPUB directly from Writer
LibreOffice Writer’s EPUB export lacks many features. However, if 
your document has an uncomplicated layout, you may be able to get 
an acceptable result using Writer’s EPUB export tool.

If you decide on this method, choose File > Export As > 
Export as EPUB.

Version
EPUB 3.0 is currently the most popular version. Version 2.0 may
not support all the formatting you want, but your publishing 
service may require it.

Split method
How the EPUB starts a new page. The most common choice is 
Heading: new pages are started each time a Heading paragraph 
style appears. With this method, you probably want two or, at 
most, three Heading styles; otherwise each page may be very 
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short, and readers may become annoyed at constantly changing 
pages. The alternative is Page break, which follows the manual 
page breaks you add in the source file. Of the two, Heading 
requires the least work and maintenance. Some publishing 
services may allow only Heading.

Layout method
Choose Reflowable to have the ebook layout change according to
screen and window size, or Fixed to have the ebook layout 
remain the same under all conditions. Most readers are likely to 
prefer Reflowable, but you might choose Fixed if formatting is 
important to you. In particular, Fixed preserves the dimensions 
of graphics.

Custom cover image
The location and name of the image for the book’s cover. If no 
image is specified in this field, the EPUB will use any image in 
the media directory with a name like cover.gif, cover.jpg, 
cover.png or cover.svg. You can enter a different name here.

Custom media directory
The location of the optional directory for the cover image, 
metadata, and multimedia files. By default, the exporter looks 
for custom media and custom metadata in the current document
directory inside a folder with the same name of the document 
file name. For example, if the document name is MyText.odt, the
default media folder for cover and metadata is MyText in the 
current directory.

If you put this information somewhere else, you need to specify 
its location. For custom metadata, you must provide a file with 
same name as the original filename and with extension .xmp. 
The provided metadata will override the internal document 
metadata. In the example above, the custom metadata must exist
in the MyText directory as MyText.xmp.

Metadata
The basic information for the file that provides tags to help 
searches. The dialog has fields for Identifier (usually the ISBN), 
Author, Title, Language, and Date. These fields override the 
document default metadata. They can be left empty.
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Exporting to EPUB from Calibre
Calibre’s ability to convert to a ebook format is far more advanced 
than Writer’s, and it fully supports Writer files. If you cannot create 
a good EPUB using Writer’s export tools, then save the document as
an ODT (LibreOffice) file and import it into Calibre:

Start Calibre, select Add books, navigate to the ODT file, select 
it, and click Open.

When the ODT file is listed in Calibre, highight the file and click 
Convert books. You can output one format at a time.

The dialog for format conversion shows the original format in 
the upper left, and the format to convert to in the upper right. The 
dialog also has fields for specifying the cover image, and for setting 
basic metadata, such as Title, Author, Publisher, Tags, and Series, 
and an unnamed field for any comments.
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If Calibre finds no cover image, it will use a generic design, as 
shown above. You can change the cover image here, before 
conversion, or later by editing the metadata (see page 112).

Notice the other choices in the left column (Look & feel, Page 
setup, Table of contents, and so on). Calibre provides very powerful 
tools for working with ebooks. It’s best to leave these alone for now, 
but if you want to delve into them, please see the user guide for 
Calibre, https://calibre-ebook.com/help 

When you have finished entering the settings, click the OK 
button at the bottom right. While the file is being created, you are 
returned to the Calibre main window. When the conversion is 
complete, you will see the file type listed on the right side of the 
window under the cover image.

Checking and manually editing 
Whatever method you use, open the newly created EPUB file and 
check the layout, preferably line by line.

If you want more control over the appearance of your ebook, you
can edit the CSS code using Calibre. CSS is not complicated, but if 
you have never worked with HTML or similar code before, it can be 
a bit intimidating. How to use Calibre for this purpose is covered in 
Bruce Byfield’s forthcoming book Designing Ebooks, or consult the 
user guide for Calibre. https://calibre-ebook.com/help 
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Editing metadata in Calibre
To add or change metadata, including the cover image, ISBN, date 
of publication, and so on, go to the Calibre main window, select the 
book in the center pane, and click Edit metadata on the icon bar 
at the top. 

Tip
The Ids field can be used for several types of identifier. To add 
an ISBN, click the icon to the left of the field and type or paste 
the ISBN into the pop-up box.

Converting to other ebook formats
Even if you export to EPUB using LibreOffice, you may want to 
provide additional ebook formats. The most commonly used is
MOBI, the format used on Kindle and other devices.

To convert to other formats, add the book to Calibre and follow 
the procedure described in “Exporting to EPUB from Calibre” on 
page 110.
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Part 2: Extras

The first eight chapters of this book covered topics that every 
self-publisher needs to know about using Writer for writing and 
publishing books.

The next eight chapters cover topics that may be relevant to 
your book or your use of Writer, but are not needed by everyone.

  9  Include illustrations
10  Add table of contents
11   Add an index
12  Create special effects
13  Track changes
14  Use templates
15  Customize Writer
16  Use online publishing services





9 Include illustrations

Illustrations in Writer are of three basic types:
• Image files such as photos, drawings, and scanned images
• Diagrams created using Writer’s drawing tools
• Charts created using LibreOffice’s Chart facility
This chapter covers images and diagrams. More detailed 

descriptions on working with drawing tools are in the Draw Guide 
and Impress Guide. How to create charts is described in the Calc 
Guide.

Creating and editing images
Images (also called ‘pictures’ in LibreOffice and in this book) might 
be created with a graphics program, scanned, or downloaded from 
the Internet (if you have permission to use them), or they might be 
photos from a digital camera.

Writer can import various vector (line drawing) and raster 
(bitmap) file formats. The most common are GIF, JPG, PNG, and 
BMP.

Some things to consider when choosing or creating images 
include image quality and whether the image will be printed in color
or grayscale (‘black and white’).

Use a resolution of 300–600 dpi (dots per inch) for photos and 
line drawings. Be careful with downloaded artwork, which is often at
72 dpi—it may be suitable for display on a screen but it is not good 
for printing.

To edit photos and other bitmap images, use a bitmap editor. To 
edit line drawings, use a vector drawing program. You do not need 
to buy expensive programs. Open-source (and usually no-cost) tools
such as GIMP (bitmap editor) and Inkscape (vector drawing 
program) are excellent. These and many other programs work on 
Windows, macOS, and Linux.
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For best results:
• Create images that have the exact dimensions required for 

the document, or use an appropriate graphics package to 
scale photographs and large drawings to the required 
dimensions. Do not scale images with Writer, even though 
Writer has tools for doing this, because the results might not 
be as clear as you would like.

• Do any other required image manipulation (brightness and 
contrast, color balance, cropping, and so on) in a graphics 
package, not in Writer, even though Writer has the tools to do
a lot of these things too.

Prepare images for black-and-white printing
If color images are to be printed in grayscale, check that any 
adjacent colors have good contrast and print dark enough. Test by 
printing on a black-and-white printer
using a grayscale setting. Better still:
change the “mode” of the image to
grayscale, either in a photo editor or in
Writer itself (see “Image mode” on page
120).

For example, the top diagram to the
right looks good in color. The circle is
dark red and the square is dark blue. In
grayscale, the difference between the two
is not so clear. A third element in the
diagram is a yellow arrow, which is
almost invisible in grayscale.
Changing the colors of the circle and the
arrow improves the contrast and visibility of the resulting grayscale 
image. A better result can often be obtained by choosing grayscale 
fills, not color fills, especially if you do not intend to sell the PDF or 
convert it to EPUB or another ebook format.

Inserting an image from a file
When the image is in a file stored on your computer, you can 
immediately insert it into the Writer document.

To insert an image from a file, use either of these methods.
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Drag and drop

1 Open a file browser window and locate the image you want to
insert.

2 Drag the image into the Writer document and drop it where 
you want it to appear. A faint vertical line marks where the 
image will be dropped.

Insert Image dialog

1 Click in the location in the Writer document where you want 
the image to appear.

2 On the menu bar, select Insert > Image.

3 On the Insert Image dialog, navigate to the file to be inserted,
select it, and click Open.

At the bottom of the Insert picture dialog are two options, Link 
and Preview.

Select Preview to view a small image of the selected graphic file 
on the right, so you can verify that you have the correct file.

Select Link to create a link to the file containing the image, 
instead of embedding (saving a copy of) the image in the document.

If you link to an image, then the image is displayed in the 
document, but the saved document contains only a reference to the 
image file—not the image itself. The document and the image 
remain as two separate files, which are temporarily merged together
only when you open the document again.
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The main advantage to linking images comes during the draft 
phase of writing and illustrating a book. If you change an image but 
keep the same filename and location on your computer, then the 
next time you open the book file, the changed image is included. 
You don’t have to remember to replace the earlier version with the 
revised image, which is what you have to do when you embed.

A minor advantage to linking images is a smaller file size for the 
main document. For most people, file size is no longer the problem 
it was some years ago.

The main disadvantage to linking comes if you need to send the 
file to someone else, or when you copy or move it to another 
computer or another location on the same computer. In these 
situations, you must make sure that the image files remain in the 
same location relative to the text file. Keeping all the files in one 
folder and sending or moving the whole folder is the easiest way to 
make sure that the files stay together.

You can embed linked images into the main file at any time.

1 Open the document in Writer and choose Edit > Links to 
External Files from the menu bar.

2 The Edit Links dialog shows all the linked files. In the Source
file list, select the files you want to change from linked to 
embedded.

3 Click the Break Link button. In the pop-up confirmation 
box, click Yes. Close the Edit Links dialog.

4 Save the Writer document.
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Inserting images from other sources
You can insert images from a graphics program, a scanner, and the 
Gallery.

Graphics program
You can use many different graphics programs to edit an image. You
can either save the edited image as a file and insert it as described 
earlier, or insert the image directly from the graphics program into 
your Writer document. Follow these steps:

1 In the graphics program window, select an area of the image 
to be copied (or select the entire image).

2 Move the cursor over the selected area and press Control+C 
(or right-click and select Copy).

3 Keep the graphics program open, but switch to the Writer 
window.

4 Click to place the cursor where the image is to be inserted. 
Press Control+V (or right-click and select Paste).

Scanner
If a scanner is connected to your computer, Writer can call the 
scanning application and add the scanned image to the document in
one step. Use Insert > Media >Scan. However, this procedure 
probably will not give you a high-quality image that is of the correct 
size. You will get better results by scanning material into a graphics 
program and editing it there before inserting it into Writer.

LibreOffice Gallery
The Gallery contains images that you can use in your documents. 
In addition to the clip art that comes with Writer, you can add your 
own images or find extensions containing more images. For more 
about the Gallery, see Getting Started with LibreOffice.

To insert a Gallery image into a document:

1 Click on the Gallery icon in the sidebar.

2 Select the theme containing the image you want to insert.

3 Drag and drop the image into the document, or right-click on
the image and select Insert.
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Modifying an image
When you insert a new image, you may need to modify it to make it 
more suitable for the document.

Although Writer provides many tools for working with images, 
for best results it is generally better to use an image manipulation 
program such as GIMP to modify images (for example, to crop, 
resize, rotate, and change color values) and then insert the result 
into Writer.

Use the Image toolbar
When you insert an image or select one that is present in the 
document, the Image toolbar appears. This toolbar can be either 
floating or docked.

Two other toolbars can be opened from this one: the Filter 
toolbar and the Color toolbar.

From these three toolbars, you can apply small corrections to 
graphics or obtain special effects. See the Writer Guide for a 
complete listing of these tools. Here are some of them.
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Image mode
Some print-on-demand services may want all graphics to be in 
grayscale, if the book is to be printed in black-and-white. If you 
have not changed color images to grayscale in a graphics 
program, you can do it here. Select the image, and then select 
Grayscale from the Image Mode list.

Crop
To crop (cut off) parts of an image, select the image and then 
click the Crop icon. Crop marks appear around the image. See 
“Crop an image” on page 121 for more information.

Flip or rotate 
To flip an image vertically or horizontally, or rotate an image 90 
degrees to the right or left, select the image and then click the 
relevant icon. See also “Flip or rotate an image” on page 123.

Transparency

Do not use transparency for print-on-demand books, because 
the printing service might not accept the resulting PDF. Ebooks 
will also fail quality control if any images have transparency.

Use the Object toolbar and right-click menu
When you insert an image or select one that is already in the 
document, the Object toolbar appears. This toolbar is usually 
docked just below the main toolbar, but it can be made to float.

The Object toolbar has icons for basic wrapping, alignment, 
anchoring, borders, and other functions. Right-clicking on an image 
pops up a menu of functions similar to those on the Object toolbar. 
See the Writer Guide for details.

Use the Image dialog
Use the Image dialog for more control over images. Cropping, 
borders, wrapping, and other functions are accessed through this 
dialog. The functions are described in detail in the Writer Guide.

Crop an image
Sometimes you might want to crop (cut off) parts of an image. It’s 
best to do this in a graphics package, but you can do it in Writer 
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using a right-click menu option, an Image toolbar option, or the 
Crop tab in the Properties dialog.

The right-click menu option and the Image toolbar option cause 
crop marks to appear around the image. You can drag one or more 
of these marks to quickly crop the image.

For more control over the results, choose Properties from the 
right-click menu. In the Image dialog, go to the Crop tab. To crop 
the image, enter amounts  in the Left, Right, Top, and Bottom 
boxes. For example, a value of 2 cm in the Bottom box cuts 2 cm 
from the bottom of the picture, as shown in the preview.
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Flip or rotate an image
Writer provides several ways to flip or rotate an image: main menu 
options, right-click menu options, Image toolbar options, and the 
Image tab in the Properties dialog.

To flip or rotate using a menu option, select the image, then 
right-click and select the flip or rotation required.

To rotate interactively, choose the Rotate menu option or the 
Rotate icon on the toolbar. Use the red handles at the corners of 
the picture and move the mouse in the direction you wish to rotate.

Tip
The rotation angle is restricted to multiples of 15 degrees. To 
rotate freely, hold down Shift while moving the mouse.

For more control, right-click on the image and choose 
Properties to open the Image dialog. In the bottom section of the 
Image tab, you can specify a precise rotation angle.

Positioning images within the text
When you add an image to a text document, you need to choose how
to position it. Writer is not a desktop publishing program, so there 
are some limitations to the positioning of images. Also, the best 
choices for producing a PDF and an ebook may be different.
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Positioning is controlled by four settings:
• Arrangement refers to the stacking position of an image 

relative to other images or text.
• Alignment refers to the vertical or horizontal placement of 

the image in relation to the anchor point.
• Anchoring refers to the reference point for the image. This 

point could be the page, the frame where the image is, a 
paragraph, or even a character. An image always has an 
anchor point.

• Text wrapping refers to the relation of images to the text 
around it. The text might treat the image as a separate 
paragraph or character, it might wrap around the image on 
one or both sides, or it might be behind or in front of the 
image.

You can access these settings in these ways:
• From the Format menu: Anchor, Wrap, and Arrange
• From the right-click menu, which also includes Align
• From the Object toolbar when an image is selected
• From the Type and Wrap tabs of the Image dialog

Arrange images
Arrangement is only relevant when objects are overlapping. You can
choose between four settings:

• Bring to Front: Places the image on top of any other 
graphics or text.

• Forward One: Brings the image one level up in the stack. 
Depending on the number of overlapping objects, you may 
need to apply this option several times to obtain the desired 
result.

• Back One: The opposite of Forward One; sends the selected 
object one level down in the object stack.

• Send to Back: Sends the selected image to the bottom of the
stack, so that other graphics and text cover it.

Note
Arrangement is lost during ebook creation. If you want to have 
overlapping images in an ebook, you need to create a single 
image in a graphics program and use that instead.
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Anchor images
You can anchor images as a character or to a page, paragraph, 
character, or frame. The method you choose depends on what you 
are trying to achieve, and whether it’s for a PDF or an ebook.

To Page
The image keeps the same position in relation to the page 
margins. It does not move as you add or delete text or other 
graphics. This method is useful when the image does not need to
be visually associated with a particular piece of text. It is often 
used when producing newsletters or other documents that are 
very layout intensive, or for placing logos in letterheads. It is not 
relevant to ebooks.

To Paragraph
The image is associated with a paragraph and moves with the 
paragraph. It may be placed in the margin or another location. 
This method is a good alternative to using a table for placing 
images next to paragraphs. The placement of the image may 
change during ebook conversion.

To Character
The image is associated with a character, but it is not in the text 
sequence. It moves with the paragraph but may be placed in the 
margin or another location. This method is similar to anchoring 
to a paragraph. The placement of the image may change during 
ebook conversion.

As Character
The image is placed in the document like any other character 
and, therefore, affects the height of the text line and the line 
break. The image moves with the paragraph as you add or delete 
text. This method is useful for keeping images in sequence in a 
procedure (by anchoring them as a character in a blank 
paragraph) or for adding a small (inline) icon in a sentence. This 
method works well for ebooks if the anchor is in a blank 
paragraph, but icons within a sentence may not remain in place.

To Frame
If the image has been placed in a frame, you can anchor the 
graphic in a fixed position inside the frame. The frame can then 
be anchored to the page, a paragraph, or a character.
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Align images
Once you have established the anchor point of the image, you can 
decide on the position of the image relative to this anchor. This is 
called aligning the image. Alignment is generally ignored when 
converting to ebooks.

Choose from six options: three for aligning the graphic vertically 
(top, center, bottom) and three for aligning the graphic horizontally 
(left, center, right). Horizontal alignment is not available for images 
anchored as a character.

For finer control of the alignment, use the Position options on 
the Type page of the Image dialog. In the example below, the upper-
left corner of the image will be placed 3 cm from the left margin of 
the page horizontally and on the top margin vertically.

Wrapping text around images
The Wrap setting determines the relation between the text and the 
image. It is normally selected after the anchoring and the alignment
have been set. You can right-click and select from these options:

• Wrap Off: Text is placed above and below the image but not 
around it. 

• Page Wrap or Optimal Page Wrap: Text flows around the
image. Moving the image around the page makes the text fill 
the space to the left and right. If the distance between the 
object and the page margin is less than 2 cm, the text is not 
wrapped on that side.

• Wrap Left and Wrap Right: Text flows on the specified 
side only.

• Wrap Through: Superimposes the image on the text. This 
option must be used with the image-transparency setting in 
order to make the text under the picture visible. It is usually 
not suitable for creating PDFs to be printed by print-on-
demand services.
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• In Background: Similar to Wrap Through but the image is 
placed behind the text. You do not need to change the 
transparency to make text visible.

Notes
When you anchor an image as character, no wrapping options 
are available. Wrapping is generally ignored when converting to 
an ebook.

To fine tune the wrapping options, open the Image dialog and select 
the Wrap tab.

This tab is divided into three sections. In the top part you can 
select from the wrap types mentioned above, plus two additional 
wrap formats: After prevents the text from filling the area to the 
left of the image, and Before prevents the text from filling the area 
to the right.

Use the Spacing section of the tab to adjust the spacing between 
the image and the text.

Example: page wrapping
The picture below is an example of page wrapping in action. To 
accomplish page wrapping:

1 Insert the image into the document, then anchor it to the 
first paragraph by selecting the image and moving it until the
anchor symbol is at the beginning of the paragraph.

2 Use either the mouse or the advanced settings to align the 
image so that the left of the image is in line with the 
paragraph indentation. In the example, the image is placed 1 
cm from the left margin.

3 Change the wrap to Page Wrap. To increase the space 
between image and text, go to the Wrap page of the Picture 
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dialog and set the image and text gap (in the Right and 
Bottom boxes) to 0.2 cm.

4 Change the position so that the image is below the first line 
of the paragraph. Again, use the mouse to drag the image or 
use the advanced settings.

Example of image with Page Wrap formatting

Using Writer’s drawing tools
Avoid using Writer’s drawing tools to create graphics or annotate 
other images. The results can be unpredictable.

• The stacking order of drawing objects does not always stay 
the way you set it, so a line or circle that should be on top of 
another object may suddenly end up underneath the object.

• You cannot group images and drawing objects together, so 
they may get out of alignment in your document.

• If you convert a Writer document to another format, such as 
HTML or EPUB, the drawing objects and the graphics will 
not remain associated; they are saved separately.

To avoid potential problems, use a graphics package such as
LibreOffice Draw or GIMP to create the graphics, then either copy 
the graphics directly into the Writer document or export them as an 
image file and import that file into Writer.
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10 Add table of contents

Does your book need a table of contents? Novels often don’t have 
them, but non-fiction books and collections of short stories or 
poetry usually do. Writer (like other word processors) provides a 
convenient way to compile an automated table of contents from the 
headings in your book.

This chapter shows you how to:
• Create a table of contents quickly, using the defaults
• Define a hierarchy of headings
• Customize a table of contents

Before you start, make sure that the headings are styled 
consistently. Writer’s built-in styles for chapter titles and 
subheadings are Heading 1, Heading 2, Heading 3, and so on. 
Headings with these styles will appear in the table of contents.

 You can use any styles you wish for the headings, including 
custom styles, but if you do, you will have to make some other 
changes, described later in this chapter.

Note
Ebooks generally have a table of contents (TOC) that is created 
during the conversion process. In that case, a TOC created and 
designed as described in this chapter is irrelevant.

Creating a table of contents quickly
Although a table of contents (TOC) can be customized extensively in
Writer, the default settings are usually fine until you get to the final 
stages of book design and layout.

To quickly create a table of contents:

1 When you create your book, use the built-in paragraph styles 
for the headings (chapter titles and subheadings): Heading 1,
Heading 2, and Heading 3.

2 Click in the document where you want the TOC to appear.
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3 Select Insert > Table of Contents and Index > Table of
Contents, Index or Bibliography.

4 Change nothing else in the dialog. Click OK. The result will 
be a typical table of contents.

Tips
• If some of your headings don’t show up in the generated TOC,

check that the headings have been tagged correctly. If a whole
level of headings doesn’t show up, see “Defining a hierarchy 
of headings” on page 130.

• You can customize an existing TOC at any time. Right-click 
anywhere in it and select Edit Index from the pop-up menu.
Continue as described on page 132.

• The TOC appears with a gray background. This background is
not printed and does not appear in a PDF. To turn off this 
gray background, go to Tools > Options > LibreOffice > 
Application Colors, then scroll down to the Text 
Document section and uncheck the option for Index and 
table shadings.
This change may leave a gray background showing behind the
dots between the headings and the page numbers, because 
the dots are part of a tab. To turn that shading off, go to 
Tools > Options > LibreOffice Writer > Formatting 
Aids and uncheck the option for Tabs.

Defining a hierarchy of headings
Paragraph styles are the key to Writer’s automatic TOC feature. The 
paragraph styles assigned to outline levels by Writer are the heading
styles supplied with Writer: Heading 1, Heading 2, Heading 3, and 
so on.

Tools > Chapter Numbering defines the hierarchy of 
headings in a document. This name is misleading: your headings do 
not need to have chapter or other numbers.

If you are using the default heading styles for the headings in 
your outline, and you do not want to use automatic numbering of 
chapter titles, you do not need to do anything on the Chapter 
Numbering dialog except verify that the correct styles are given for 
each heading level you want to be shown in the TOC.

130 Chapter 10  Add table of contents



Choose paragraph styles for heading levels
To use custom paragraph styles instead of one or more of the default
heading styles, or to use automatic heading numbering for the 
chapter titles:

1 Be sure the custom paragraph styles have been defined. For 
our example, we’ll use only one: Chapter Name for the 
chapter titles.

2 Click Tools > Chapter Numbering to open the Chapter 
Numbering dialog.

3 Click the number in the Level box that corresponds to the 
heading for which you want to change the paragraph style. In
our example, this is Level 1.

4 In the Numbering: Paragraph Style section, choose from the 
drop-down list the paragraph style that you want to assign to 
that heading level. In our example, choose Chapter Name to 
replace Heading 1.

5 Repeat for each outline level that you want to change. Click 
OK when done.
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Customizing a table of contents
You can alter the content and appearance of a TOC in several ways.

To customize a TOC, right-click anywhere in it and choose Edit 
index from the pop-up menu.

The Table of Contents, Index or Bibliography dialog has five 
tabs. Any or all of them can be used when creating or editing a TOC:

• Use the Type tab to set the attributes.
• Use the Entries and Styles tabs to format the entries.
• Use the Columns tab to have more than one column.
• Use the Background tab to add color or a graphic to the 

background.

You can display a preview box, located on the right-hand side of 
the dialog, to show as you work how the TOC will look. (If you do 
not see the preview box, select the Preview option in the lower left-
hand corner of the dialog.) The illustrations in this chapter show the
dialog as it appears with the preview box hidden.

After making all of your changes, click OK to save the TOC so 
that it appears in your document.

Type tab
Use the Type tab to set the attributes of the TOC.
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Change the title
To give the TOC a different title, type it in the Title field. To 
delete the title, clear the Title field.

Set the type of index
In computer terminology, a table of contents is one of several 
types of indexes. Be sure the Type is set to Table of Contents. 
(In the chapter on indexes, we’ll use this same dialog but choose 
“Alphabetic Index” and a different set of options. We won’t look 
at the other index types.)

Choose the scope of the table of contents
From the for drop-down list in the Create index or Table of 
Contents area, select Entire document. There is an additional 
option to create a TOC for just the current chapter.

Change the number of levels included
Writer uses up to 10 levels of headings when it builds the TOC. 
To change the number of levels, enter the required number in 
the Evaluate up to level box.

Protect against manual changes
To prevent the TOC from being changed accidentally, select the 
Protected against manual changes option. The TOC can 
then only be changed using the right-click menu or the Table of 
Contents, Index or Bibliography dialog. If the box is not checked,
the TOC can be changed directly on the document page just like 
other text, but any manual changes will be lost when you update 
the TOC.

Create a table of contents from an outline
Select the Outline option to create the TOC using outline levels;
that is, using paragraphs formatted with the styles specified in 
the Chapte Numbering dialog. This is the method used for most 
books.

Create from index marks
This is an advanced feature not normally used for a TOC, so 
deselect this option. We’ll look at index marks in Chapter 11.
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Create from additional styles
Writer automatically includes in the TOC all paragraphs that 
have been formatted with the paragraph styles selected in Tools
> Chapter Numbering. You might also wish to include 
headings formatted with other styles. For example, you might 
have styles for appendix titles or for the title of an Index page, 
and you might want those titles to appear in the TOC at the same
level as the chapter titles. You can do this in two ways.

Method 1

1 In the Create from area, select Additional Styles and click 
the (...) button to the right. The Assign Styles dialog opens.

2 Click the style that you want to assign to the TOC, then click 
the circle corresponding to the outine level required.

3 Click OK to save your changes and return to the Type page 
or click Cancel to return without saving your changes.

Method 2

1 In the Paragraph Style dialog for the paragraph you want to 
include, go to the Outline & Numbering tab.

2 Under Outline level, select the required level from the drop-
down list. Click OK to save.
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Entries tab
Use the Entries tab to define and format the entries in the TOC. For 
each outline level, you can add and delete elements such as chapter 
(heading) numbers. You can also apply character styles to individual
elements.

To begin, click a number in the Level column to select the 
outline level whose elements you want to format. (You will be able 
to apply changes to all outline levels later.) The Structure line 
displays the elements for entries in that level. Each button on the 
Structure line represents one element.

• The E# button represents the “chapter number” (heading 
level). This number is for all levels of headings.

• The E button represents the text of the heading.
• The T button represents a tab.
• The # button represents the page number.
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• The LS button represents the start of a hyperlink.
• The LE button represents the end of a hyperlink.
Each white field on the Structure line represents a blank space. 

If you wish, you can add custom text such as the word Chapter.

Add elements
To add an element to the Structure line:

1 Click in the white field where you want to insert the element.

2 Click one of the five buttons just below the Structure line. 
(For example, to add a tab, click the Tab Stop button.) A 
button representing the new element appears on the 
Structure line.

3 To add custom text, type the text in the white field.

Delete elements
To delete an element from the Structure line, click the button 
representing that element and then press the Delete key on the 
keyboard.

Apply character styles
You might want an element to be a bit different from the rest of the 
line. For example, you might want the page number to be bold. To
apply a character style to an element:

1 Be sure you have defined a suitable character style.
2 On the Structure line, click the button that represents the 

element to be changed.
3 From the Character Style drop-down list, select the desired 

style.

To view or edit the attributes of a character style, select the style 
from the Character Style list and then click the Edit button.

Tip
The default character style for hyperlinks is Internet Link. By 
default, this style is blue and underlined.

If you want the TOC entries to be hyperlinks, but not appear 
underlined and blue, select the LS button on the Structure line 
and change the character style selection to Index Link. Click the 
Edit button to change the settings for Index Link.
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Apply changes to all outline levels
To apply the displayed structure and formatting to all outline levels, 
click the All button.

Tab position relative to Paragraph Style indent
When this option is selected, entries are indented according to the 
settings of their individual formats. When a paragraph style 
specifies an indent on the left, tab positions are relative to the 
indent. If this option is not selected, tab positions are relative to the 
left margin position.

Styles tab
Use the Styles tab to change which paragraph style is assigned to 
each level in the TOC. In most cases, the best strategy is to keep the 
assigned styles but change their settings as needed to make the TOC
appear the way you want.

If you define custom styles, do this to apply them to the TOC:

1 In the Levels list, select the outline level.
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2 In the Paragraph Styles list, click the desired paragraph 
style.

3 Click the < button to apply the selected paragraph style to 
the selected outline level.

The style assigned to each level appears in square brackets in the
Levels list.

To remove paragraph styling from an outline level, select the 
outline level in the Levels list, then click the Default button.

To view or edit the attributes of a paragraph style, click the style 
in the Paragraph Styles list, then click the Edit button.

Columns tab

Multiple columns are more commonly used in indexes. To change 
the number of columns in a TOC, see “Columns tab” in Chapter 11.

Background tab
Use the Background tab to add color or a graphic image to the 
background of the table of contents. This is not commonly done in 
books with black-and-white interiors.

Maintaining a table of contents
To edit an existing TOC, right-click anywhere in it and choose Edit 
index from the pop-up menu. The Table of Contents, Index or 
Bibliography dialog opens and you can edit and save the table as 
described in the previous section.

Writer does not update the TOC automatically, so after any 
changes to the headings, you must update it manually. To update a 
TOC when changes are made to the document, right-click anywhere 
in it and choose Update index from the pop-up menu. Writer then
updates the TOC.

To delete a TOC from a document, right-click anywhere in it and 
choose Delete index from the pop-up menu. Writer does not 
prompt you to confirm the delete.

Tip
If you cannot right-click in the table of contents, go to Tools > 
Options > LibreOffice Writer > Formatting Aids and 
select Enable cursor in the Protected Areas section.
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11 Add an index

Does your book need an alphabetic index? Novels and collections of 
short stories or poetry usually don’t have them, but non-fiction 
books usually do.

The index is usually in the back of a book. It list words and 
phrases and their locations in the book. Indexes are not so relevant 
to ebooks because the search function serves the same purpose.

Writer, like other word processors, provides a convenient way to 
build an automated index from index entries that you define in the 
book.

This chapter describes how to:
• Add index entries to the book
• Build an alphabetic index quickly
• Customize the display of index entries
• View and edit existing index entries

Adding index entries
Before you can build an index, you must add some index entries to 
the book. To do this:

1 Highlight the word or phrase to add to the index, or click at 
the beginning of the word or phrase. (To add multiple words 
as one entry, highlight the entire phrase.)

2 Click Insert > Table of Contents and Index > Index 
Entry to display a dialog similar to the one shown on the 
next page. You can accept the word or phrase shown in the 
Entry box or change it to whatever you want.

See “Customizing index entries” on page 141 for an 
explanation of the fields on this dialog.

3 Click Insert to create the entry.
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You can insert multiple entries without closing the dialog:

1 For each one, click at the location (or select the words) in the 
document that you want to include in the index.

2 Click again on the dialog. Click the icon to the right of the 
Entry box to change it to the selected term.

3 Change the entry if needed, and click Insert.

4 Repeat steps 1–3 until you have finished inserting index 
terms, then click Close.

Tip
You can also open the Insert Index Entry dialog by clicking the 
Insert Index Entry icon on the Insert toolbar.

Note
If field shading is active (View > Field shadings), then a word 
or phrase that has been added to the index is shown in the text 
with a gray background. Index entries containing text that is 
different from the text in the document (including capitalization 
differences) are marked by a small gray rectangle.
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Customizing index entries
These are the fields in the Insert Index Entry dialog.

Index
The type of index that this entry is for. The default is 
Alphabetical Index, but you can use this field to create extra 
entries for an index or list of almost anything. For example, you 
might want an index containing only the scientific names of 
species mentioned in the text along with a separate index 
containing only the common names of species.

Entry
The word or phrase to be added to the index. This word or 
phrase does not need to be in the document itself. You can add 
synonyms and other terms that you want to have in the index.

1st key
An index key is an entry that has no associated page number and
has several subentries that do have page numbers. Using keys is 
a useful way of grouping related topics. (See “Example of using 
an index key” on page 142.)

2nd key
You can have a three-level index, where some of the first-level 
keys have level-2 entries that are also keys (without page 
numbers). This degree of complexity is not often necessary.

Main entry
When the same term is indexed on several pages, often one of 
those pages has more important or detailed information on that 
topic. To make the page number for the most important (main) 
entry stand out, select this option and then define the character 
style for the page number of a main index entry to be bold.

Apply to all similar texts
Select this option to have Writer automatically identify and mark
as an index entry any word or phrase that matches the current 
selection. The Match case and Whole words only options 
become available if this option is selected. Use this option with 
care, as it may result in many unwanted page numbers being 
listed in the index.
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Example of using an index key
An index key is a primary entry that has subentries. For example, 
you might want to create a grouping similar to this:

LibreOffice
      Calc  10, 25
      Impress  15
      Writer  5, 11

In this example, LibreOffice is the 1st key. The subentries (with 
the page numbers showing) are the indexed entries. To insert an 
index entry for the topic Writer, on the Insert Index Entry dialog, 
type Writer in the Entry box and LibreOffice in the 1st key box.

Building an alphabetic index quickly
Now that you have some index entries, you can build the index.

Although indexes can be customized extensively, usually you 
need to make only a few choices. To create an index quickly:

1 Click in the document where you want the index to appear.

2 Select Insert > Table of Contents and Index > Table of
Contents, Index or Bibliography.
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3 In the Type box on the Type page, select Alphabetical 
Index.

4 In the Options section, select Combine identical entries, 
uncheck Case sensitive (so that capitalized and lower-case 
words will be treated as the same word), and uncheck 
Combine identical entries with p or pp.

5 Click OK. The result will be a typical index.

Customizing an index
You can customize an index in numerous ways.

To customize an existing index, right-click anywhere in the index
and choose Edit index from the pop-up menu.

The Table of Contents, Index or Bibliography dialog has five 
tabs. Any or all of them can be used to customize the appearance of 
an index.

• Use the Type tab to set the attributes.
• Use the Entries and Styles tabs to format the entries.
• Use the Columns tab to specify more than one column.
• Use the Background tab to add color or a graphic to the 

background.

You can display a preview box, located on the right-hand side of 
the dialog, to show as you work how the index will look. (Select the 
Preview option in the lower left-hand corner of the dialog.) The 
illustrations in this chapter show the dialog as it appears with the 
preview box hidden.

After making all your changes, click OK to save the index.

Type tab
Use the Type tab to set the attributes of the index.

1 To give the index a different title, type it in the Title field. 
(You can change an existing title by typing over it.) To delete 
the title, clear the Title field.

2 Be sure the Type is set to Alphabetic Index.

3 To prevent the index from being changed accidentally, select 
the Protected against manual changes option. The 
index can then only be changed using the right-click menu or
the Table of Contents, Index or Bibliography dialog. If the 
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box is not selected, the index can be changed directly on the 
document page just like other text, but any manual changes 
will be lost when you update it.

4 From the drop-down list in the Create index/table area, 
select Entire document. You can also choose to create an 
index for just the current chapter.

5 Various other options determine how the index handles 
entries:

• Combine identical entries. Defines how identical 
entries are dealt with. Normally each page number of an 
indexed word or phrase is shown in the index, but page 
numbers can be combined using these options. If you 
want a page range displayed, select Combine with – 
(which will produce something similar to 23–31). If you 
want different entries based on what letters are 
capitalized, select Case sensitive.

• AutoCapitalize entries. Automatically capitalizes the 
first letter of each index entry regardless of how the words
are capitalized within the document.

• Keys as separate entries. Makes the index keys have 
their own page numbers.

• Concordance file. Allows a list of words in an external 
file to be imported (selected using the File button) and 
then used within the index. For more information, see 
concordance file in the help. Using a concordance file can
speed up production of an index, but unless the words are
very carefully selected and unless you edit the index 
afterward, the resulting index can be full of page numbers
for minor mentions of a term.

• Sort. Defines how the entries are sorted when displayed. 
The only option is alphanumeric, but you can specify 
which language alphabet is to be used.

Entries tab
Use the Entries tab to define and format the entries in the index.
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To begin, click a number in the Level column to select the index 
level whose elements you want to format. (You will be able to apply 
your changes to all index levels later.)

The Structure line displays the elements for entries in that level. 
This line works the same way as for a TOC; see page 135 for details.

Each of the items that can be added to the Structure line may 
have additional formatting. For example, you may want the page 
number to be a different size from the rest of the index text. To do 
this, apply a character style to one of the elements in the Structure 
line, as described for TOCs.

Formatting entries
You can apply additional formatting using the options in the Format
section.

Alphabetical delimiter
This will display, as a means of separating index entries, the 
letter of the alphabet for the index entries that follow. For 
example:

        A
        apple, 4
        author, 10

        B
        break, 2
        bus, 4
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Key separated by commas
Arranges the entries in the index on the same line but separated 
by commas.

Tab position relative to paragraph style indent
Indents entries according to the settings of their individual 
formats. When a paragraph style with an indent on the left is in 
use, tab stops will be relative to this indent. If this option is not 
selected, tab stops will be relative to the left margin position.

Columns tab
Use the Columns tab to change the number of columns in the index.

1 Choose the number of columns in the box labeled Columns,
or select the icon representing the number of columns.

2 To evenly distribute the columns according to the page 
width, check the AutoWidth box. If it is unchecked, you can
manually set both the width of each of the columns and the 
spacing between the columns.

3 You can choose to put a separator line between the columns:

• Line: The width (thickness) of the line.
• Height: The height of the line.
• Position: Position of the line relative to the columns (top, 

middle, or bottom) if the height is less than 100%.
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Styles tab
Refer to “Styles tab” on  page 137 for tables of contents.

Maintaining an index
To edit an existing index, right-click anywhere in the index and 
choose Edit index from the pop-up menu. The Table of Contents, 
Index or Bibliography dialog opens. Edit and save the index as 
described in the previous section.

Writer does not update the index automatically, so after making 
changes to the index entries, you must update it manually. To 
update an index, right-click anywhere in the index and choose 
Update index from the pop-up menu.

To delete an index, right-click anywhere in the index and choose 
Delete index.

View and edit existing index entries
After you have inserted the initial index entries into the document, 
you can add more entries or you can edit them. To view and edit 
existing entries:

1 Ensure that field shading is active, so you can locate index 
entries more easily (View > Field shadings).

2 Right-click on an existing index entry in the body of the 
document and select Index Entry from the pop-up menu.

3 A dialog similar to the one below appears. Use the forward 
and back arrow buttons to move through the index entries.

4 Make the necessary modifications to the index entries and, 
when finished, click OK, then Close.
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12 Create special effects

This chapter describes how to create a few commonly-used special 
effects using Writer:

• Drop caps
• Character spacing
• Rotating text
• Centering text vertically on a page
• Paragraph borders and backgrounds
• Page borders and backgrounds
• Header and footer special effects
• Special effects for lists

Drop caps
A drop cap is a large capital letter (or several letters or a word) that 
can be several lines in height. Some books use this design at the 
beginning of every chapter.

To define a drop cap:

1 For a single paragraph, position the cursor in the paragraph 
and choose Format > Paragraph, or right-click and 
choose Paragraph > Paragraph. 

For a paragraph style, select the paragraph style on the Styles
deck in the sidebar, right-click and choose Modify.
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2 On the Drop Caps page, choose the number of characters to 
include in the drop caps (usually this is 1), the number of 
lines for the height of the drop cap, and any extra space to 
text. You may need to experiment to find the best settings.

3 (Optional) Choose Drop Caps for the character style, if you 
want to have the drop cap in a different font from the rest of 
the paragraph. See the next topic for more on the Drop Caps 
character style.

4 Click OK when done.

Edit the Drop Caps character style
You can choose a different font for the drop cap characters. To do 
this:

1 On the Styles deck in the sidebar, click on the Character 
Styles icon at the top.

2 Right-click on Drop Caps and choose Modify. This opens 
the Character Style dialog, where you can change the font.

3 Then (as described above), on the Drop Caps page of the 
Paragraph Style dialog, choose Drop Caps for the 
Character Style.

Character spacing
You can use character spacing for a decorative effect.
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To create the effect shown above, define a paragraph style with 
extra spacing between characters. 

To set extra spacing, go to the Position tab of the Paragraph Style
dialog for the style that you want to create or change. In the Spacing 
section, enter the amount of space to be inserted between 
characters. You might need to experiment a bit to find the best 
spacing for your desired effect.

Rotating text
The Position tab for a paragraph style also controls rotation of the 
paragraph text. Two common uses for rotated paragraphs are fitting
headings above narrow table columns (as shown below) and placing 
decorative effects on a page.

A table with rotated headings
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To create the effect shown above, create a new paragraph style. 
On the Position page of the Paragraph Style dialog, in the Rotation /
scaling section, select 90 degrees. 

If you want the paragraphs in the center of the cell horizontally 
(instead of the left as in the example), go to the Alignment tab and 
choose Center in the Options. Click OK to save the new style.

Then select the heading row of the table and apply the new style. 
Any text in the cells of the heading row is now rotated.

If the headings are aligned to the top of the cells, you might want
to change the alignment to the bottom of the cells, as shown in the 
example. To do this, select the cells, and then choose Format > 
Align > Align Bottom to Anchor from the menu bar.

Centering text vertically on a page
You might want to center text vertically on a title page. To do this, 
you need to place the text in a frame and center the frame vertically 
on the page.

1 Select the text that you want to center vertically.

2 Choose Insert > Frame from the menu bar. On the Type 
tab, select AutoSize under Width, AutoSize under Height, 
To page under Anchor, and Center under both Horizontal 
and Vertical in the Position section.

3 For vertical centering, your choice between centering on the 
page text area or centering on the entire page will depend on 
the top and bottom margins of the page and the effect you 
want to achieve. 

4 Click OK to insert the frame.

5 If the frame has a border, you can remove it by going to the 
Border tab and clicking on the Set No Borders icon under 
Line Arrangement.
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Paragraph borders and backgrounds
To add a decorative element to a heading or make a quotation or 
other paragraph stand out from the text, you can give the paragraph 
a border or a colored or graphic background.

Use the Borders or Area tabs of the paragraph or paragraph style
dialogs. The options on these tabs are fairly self-explanatory, but 
you may want to consider the following points.

On the Borders tab:
• Watch out for the effects that the spacing between borders 

and paragraph area produces on indentations.
• If you want the border to be drawn around multiple 

paragraphs, mark that option at the bottom of the page.

On the Area tab:
• For best effect in black-and-white printing, choose one of the 

gray selections, not a color. 
• You can use a solid color, a gradient, a pattern, hatching, or a 

bitmap image as background, but graphic backgrounds 
generally do not reproduce well in black and white.

• The background is applied only to the paragraph area. If you 
have defined some indentations, the space between the 
paragraph and the margin remains in the page color.
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Page borders and backgrounds
Borders and backgrounds for pages are part of the page style. Use 
the Borders tab to draw a border around the text area of the page. 
Use the Area tab to apply a background. You can choose between a 
solid color, a gradient, a pattern, hatching, or a bitmap image for the
background. Choose from several line styles for the borders.

Header and footer special effects
Suppose you want to have a simple header or footer that contains 
only a page number that is visually separated from the main text by 
a thin line—but you don’t want the line to extend the full width of 
the footer area. Here’s how to do it.

Define the Footer paragraph style to have indents before and 
after the text, a center alignment, and a border above the paragraph.

The following illustrations show an example of these settings 
and the result.
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You can also place images, document information such as the 
book’s title or author, and small tables in a header or footer.

Insert a table when you want to have more than one line of text 
and when you want the information to be aligned in different ways 
(left, right, or center).

Include document information
Headers and footers often include document information such as 
the book’s title or author or the name of the chapter.

You can type this and other unchanging information into the 
header or footer, or you can use a field.

When information will change from one chapter or section to the
next, you need to use a field that displays the information that is 
relevant to each page.

To include the chapter name in a header or footer:

1 Click in the header or footer, and then choose Insert > 
Fields > Other (or press Control+F2) to open the Fields 
dialog.

2 On the Document tab, select Chapter in the Type list and 
Chapter name in the Format list.

3 Make sure that Level is set to 1, and then click Insert.

The Chapter field uses the hierarchy of headings defined in the 
Outline Numbering dialog (which also determines which headings 
go into a table of contents. See page 130).

The Level box determines which heading (outline) level is 
displayed in the field. For example, Level 1 always displays the most 
recently found heading that has the paragraph style selected for 
Level 1 in the Outline Numbering dialog, Level 2 displays the most 
recent heading with the paragraph style selected for Level 2 in 
Outline Numbering, and so on.
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Note
A Chapter field in a page header always picks up the highest 
heading level on a page, even if you have specified a lower level. 
For example, if a page has a Heading 1 and a Heading 2 on it, 
then a Level 2 Chapter name field in the header of that page will 
display the Heading 1 paragraph, not the first Heading 2 
paragraph as intended. In a footer, the levels work as intended.

Use a table to align text in headers and footers
If one or more of the items to be included in the header or footer is 
too long to fit in the space available, or you need more than one line 
of information, you can use a table for layout. The contents of each 
cell can be aligned to the left, center, or right, independently of the 
other cells.

A table in a page footer
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Place the cursor in the footer area and choose Insert > Table 
from the menu bar. Choose the number of rows and columns 
required, and click OK. A typical arrangement would be 3 columns, 
1 row, as shown in the example.

Special effects for lists
Numbers of list items are in the same font and size as the text. To 
add visual interest to numbered lists, you can make the numbers 
larger, bold, in a different font, or with other effects.

Change the Numbering Symbols character style, using the Font 
and Font Effects tabs.

Make sure the list (numbering) style has Numbering Symbols
selected as the character style on the Options tab. (You need to do 
this for each level in the list style that you wish to change.)
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13 Track changes

You can use several methods to keep track of changes made to a 
document.

• Ask editors and reviewers to use Writer’s change marks 
(often called revision marks) to show where they have added 
or deleted material or changed formatting. Later, you can 
review and accept or reject each change.

• Make changes to a copy of the document (stored in a different
folder, under a different name, or both), then use Writer to 
combine the two files and show the changes that were made. 
This technique is most useful when you are the only person 
working on the document.

• Save versions as part of the original file. Avoid this method. It
provides no real benefit to a self-publisher and can cause 
problems with larger or more complex documents, especially 
if you save a lot of versions.

The picture below shows how Writer tracks insertions and 
deletions. The change bars in the margin remain visible when the 
changes are hidden. See Chapter 2 for instructions on setting up 
how your changes will be displayed.
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Preparing a document for review
When you send a document to someone else to review or edit, you 
may want to prepare it to ensure that any changes are recorded, 
without the editor or reviewer needing to remember to turn on 
change tracking. Writer calls this protecting a document.

1 Open the document and make sure that the Edit > Track 
Changes > Record menu item is checked.

2 Choose Edit > Track Changes > Protect. On the Enter 
Password dialog, type a password (twice) and click OK. 
Passwords must contain at least one character.

Now no one can turn off change recording, or accept or reject 
changes, without entering the correct password.

Tip
Instead of using the menu items, you can use the icons on the 
Track Changes toolbar, as shown below.

Using the Track Changes toolbar
Writer provides several ways to work with track changes: a toolbar, 
menu bar items, and (after at least one change has been recorded) 
some choices on a right-click context menu.

The Track Changes toolbar is very convenient. Display it using 
View > Toolbars > Track Changes. It may appear docked at the 
bottom of the screen, just above the Find toolbar, or you can put it 
in other locations or float it.

From left to right, the icons are: Show Track Changes, Record 
Track Changes, Previous, Next, Accept, Reject, Accept All, Reject 
All, Manage, Insert Comment, Insert Track Change Comment, 
Protect, Compare, Merge. These commands are described on the 
following pages.
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Recording changes and comments
To begin tracking (recording) changes, click Edit > Track 
Changes > Record or the Record Track Changes icon on the 
toolbar. To stop recording changes, click Edit > Track Changes > 
Record or the toolbar icon again.

To add a comment to a tracked change, or edit an existing 
comment, click in the area of the change and choose Edit > Track 
Changes > Comment, or click the Insert Track Change Comment 
icon on the toolbar. The comment is shown in the list in the Manage
Changes dialog (see page 162) and in a tooltip for the change (see 
below), but it does not appear on the page. If you want the comment
to appear at the side of the page, use Insert > Comment instead 
(see page 164).

After you have recorded more than one change, you can move 
between them using the arrow buttons. If no comment has been 
recorded for a change, the Text field is blank.

Viewing recorded changes
To display or hide all changes (insertions, deletions, and 
formatting), in the document, click Edit > Track Changes > 
Show or the Show Track Changes icon on the toolbar. When 
changes are hidden, insertions and new formatting appear in the 
text and deletions are not visible.

When changes are showing, hold the mouse pointer over a 
tracked change to see a Help Tip that describes the type of change, 
the author of the change, and the date and time of the change. (The 
author’s name is taken from information in Tools > Options > 
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LibreOffice > User Data on the computer used by that person 
when editing the file.) If you have Extended Tips turned on (Tools 
> Options > LibreOffice > General), the comment is also visible
in a tooltip when the mouse pointer is over the change.

Accepting or rejecting changes
Changes that have not yet been accepted or rejected are listed in the 
Manage Changes dialog.

Accepting or rejecting changes removes them from this list. 
Rejected changes are also removed from the document. To have a 
record of changes, save a copy of the file before doing this step.

1 Choose Edit > Track Changes > Manage or click the 
Manage Track Changes icon on the toolbar. The Manage 
Changes dialog opens.

2 When you select a change in the dialog, the change itself is 
highlighted in the document.

3 Click Accept or Reject in the dialog or on the toolbar to 
accept or reject the selected change. You can also click 
Accept All or Reject All if you do not want to review each 
individual change.
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To show only certain types of changes, use the Filter tab of the 
Manage Changes dialog. After specifying the filter criteria, return to 
the List page to see those changes that meet your criteria.

Tip
After accepting and rejecting changes, go through the document 
and look for minor errors such as a change that incorrectly 
deleted (or failed to delete) a space between words, or major 
errors such as unwanted changes in paragraph styles.

Merging modified documents
Sometimes two or more reviewers return edited versions of a 
document at the same time. If all of the edited documents contain 
recorded changes, it may be more efficient to merge the documents 
and review all of the changes at once.

However, merged documents can sometimes be confusing to 
read, because more than one person may have changed the same 
text in different ways. You may find that dealing with one set of 
changes at a time is easier.

To merge documents:

1 Open one copy.

2 Choose Edit > Track Changes > Merge Document or 
click Merge Track Changed Document on the toolbar. Select 
the copy of the document that is to be merged with the first, 
and click Insert.
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3 After the documents merge, the Manage Changes dialog 
opens, showing changes by more than one reviewer.

4 If you want to merge another copy of document with the 
original, close the dialog and then repeat step 2.

5 Repeat until all copies are merged.

6 All recorded changes are now included in the open copy. 
Save this file under another name.

Comparing documents
If you have not protected the document, some reviewers may forget 
to record the changes they make. You can use Writer’s Compare 
Documents feature to find those changes.

To compare documents, you need to have the original document 
and the one that has been edited.

1 Open the edited document. Choose Edit > Track Changes 
> Compare Document or click Compare Non-Track 
Changed Document on the toolbar.

2 Select the original document and click Insert.

3 Writer finds and marks the changes and displays the Manage
Changes dialog. From this point, you can go through the 
document and accept or reject changes as described earlier.

Using other comments
Reviewers may want to include comments in the text, either for you 
or for other reviewers. Comments are displayed at the side of the 
page and color-coded according to the person who created them.

To insert a comment, place the cursor in the place the comment 
refers to and select Insert > Comment or press Control+Alt+C. or
click Insert Comment on the toolbar, or right-click and choose 
Comment from the context menu. 

The anchor point of the comment is connected by a line to a box 
on the right-hand side of the page where you can type the text of the 
comment. Writer automatically adds the author of the comment and
the date and time when the comment was created. (The author’s 
name is taken from information in Tools > Options > 
LibreOffice > User Data on the computer used by that person 
when editing the file.)
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You can format the text of the comments (change font type, size, 
and alignment) from the Formatting toolbar or the sidebar.

If more than one person edits the document, each author is 
automatically allocated a different background color.

Right-clicking on a comment pops up a menu where you can 
delete the comment, or all the comments from the same author, or 
all the comments in the document. 

Several people can have a discussion using comments, by right-
clicking on a comment and selecting Reply from the pop-up menu.

To navigate from one comment to another, open the Navigator 
(F5), expand the Comments section, and click on the comment text 
to move the cursor to the anchor point of the comment in the 
document.

You can also navigate through the comments using the Previous 
and Next icons in the Navigation toolbar (see page 25) or by using 
the keyboard. Control+Alt+Page Down moves to the next note and 
Control+Alt+ Page Up moves to the previous comment.
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14 Use templates

A template is a model that you use to create other documents. For 
example, you can create a template for a book chapter that contains 
the page styles, paragraph styles, header and footer contents such as
page numbers, and other information. New chapters created from 
this template will all have the same contents and appearance.

Later, you can edit the styles in a template and then update the 
documents created from that template. See “Updating a document 
when its template is changed” on page 171.

Templates can contain anything that regular documents can 
contain, including text, graphics, a set of styles, and user-specific 
setup information such as measurement units, language, the default 
printer, and toolbar and menu customizations.

All Writer documents are based on templates. If you do not 
choose a template when you start a new document, then Writer uses
the default template for text documents. You can specify a custom 
template to be the default template (see “Setting up a custom default
template” on page 172); otherwise, Writer uses the blank template 
for text documents that is installed with LibreOffice.

To see what template is associated with a document, go to File >
Properties and look on the General tab. If no template is listed, 
the document was created from the default template for text 
documents or in some other way such as copying an existing 
document.
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Creating a template
Previous chapters of this book described how to set up styles, 
headings, layout, and a sequence of pages in a document.

Here is how to create a template from that document:

1 Open the document.

2 From the main menu, choose File > Templates > Save as 
Template. The Save As Template dialog opens.

3 Type a name for the new template.

4 In the Template Category list, choose the category to which 
you want to assign the template. Usually this is My 
Templates, although you can create other categories.

5 Click Save to save the new template.

Creating a document from a template

Using the Start Center
If no document is open in LibreOffice, the Start Center is visible. 

Click the Templates icon in the left pane. The icon is also a drop-
down list to select the templates of a given type of document. The 
Manage Templates option on the list opens the Templates dialog.
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When another document is open
If a document of any type (text, spreadsheet, drawing) is open in 

LibreOffice, you can create a new Writer document this way:

1 From the main menu, choose File > New > Templates, or 
click the small arrow next to the New icon on the Standard 
toolbar and select Templates. The Templates dialog opens.

2 From the Filters list at the top, select a category.

3 Double-click the folder containing the template that you 
want to use. A list of all the templates contained in that 
folder appears in the center box.

4 Find and double-click the required template. A new 
document based on the selected template opens in Writer. 
You can then edit and save the new document just as you 
would any other document.
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Editing a template
You can edit the styles and content of a template, and then you can 
reapply the template’s styles to documents that were created from 
that template. (You can only reapply styles. Any changes to the 
content of a template, such as text in headers and footers, affect new
documents created from the template but do not affect existing 
documents.)

To edit a template:

1 From the menu bar, choose File > Templates > Manage 
Templates. The Templates dialog opens. You can also open 
the Templates dialog from the Start Center.

2 Navigate to the template that you want to edit. Right-click to 
open a context menu and choose Edit. The template opens 
in Writer.

3 Edit the template as you would edit any document. To save 
your changes, choose File > Save from the menu bar.
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Updating a document when its template is 
changed
The next time you open a document that was created from the 
changed template, a message appears asking if you want to update 
the document’s styles from the changed template.

Click Update Styles to apply the template’s changed styles to 
the document, or click Keep Old Styles if you do not want to apply
the changed styles to the document.

Caution
If you choose Keep Old Styles, the message box will not 
appear again, and you will not get another chance to update the 
styles from the template. The document is no longer connected 
to the template, even though the template is still listed under 
File > Properties > General. To reconnect the document to 
the template, you will have to copy it into an empty document 
based on the template, as described below.

Changing to a different template
At times you might want to change the template associated with a 
document, or perhaps you are working with a document that did not
start from a template. A common scenario for writers is to start with
a template designed for drafts (full size paper, double-spaced type) 
while writing and editing the manuscript, and then change to a 
template designed for final formatting (for example, 6x9-inch paper,
single-spaced type, different margins and fonts).
You can change the style definitions, but that can be a lot of work 
and it breaks the connection to the template.

Tip
For best results, the names of styles in the existing document 
and the names of the styles in the new template should be the 
same. You may wish to rename the styles in the document before
applying the new template. If the names of the styles are not the 
same, you will need to use Find & Replace to replace the old 
styles with the new ones. Note, however, that Find & Replace 
works only with Paragraph styles, not Character, Page, or Frame 
styles.  See Chapter 3 for more about replacing styles.
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1 Use File > New > Templates. In the Templates dialog, 
double-click the template you want to use.

2 Delete any unwanted text or graphics from this new 
document. Save it with a new name, but keep it open.

3 Open the document you want to change. (It opens in a new 
LibreOffice window.) Use Edit > Select All, or press 
Ctrl+A, to select everything in the document. Use Edit > 
Copy, or press Ctrl+C, to copy the contents of the document 
to the clipboard.

4 Click in the new document created in step 1. Use Edit > 
Paste, or press Ctrl+V, to paste the contents from the old 
document into the new one.

5 Update the table of contents, if there is one. Save this file.

Caution
Any changes recorded (tracked) in the document will be lost 
during this process. The resulting document will contain only 
the changed text.

Setting up a custom default template
You won’t want your book template to be the default template for 
every document you write, but you might want to set up a default 
template that is different from the one supplied with Writer. For 
example, you might prefer to use different fonts, or a different page 
size or page margins, instead of those provided in Writer’s default 
template. By setting up your own default template, you avoid having
to make those changes every time you start a new document.

You can set up a custom default template in two ways:
• When saving a document as a tempate, select the Set as 

default template option (see page 168).
• If the template already exists, go to File > Templates > 

Manage Templates. On the Templates dialog, right-click 
on the required template and choose Set as Default.

The next time that you create a new document by choosing File 
> New > Text Document, the document will be created from this 
template. The changes do not affect existing documents.
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Using predefined templates
Some templates are included with LibreOffice. Several other 
collections of templates are available as extensions to Writer. This 
page lists many of the available extensions: 
http://extensions.libreoffice.org/. See Chapter 15 for information 
about installing extensions.

After installation, these templates are listed in the Templates 
window. They are usually in separate folders.

If you obtain a template that is not in an extension, you can save 
it anywhere on your computer and then import it into a LibreOffice 
template folder:

1 Choose File > Templates > Manage Templates from the
menu bar.

2 In the Templates dialog (shown below), click the Import 
button in the lower right.

3 In the Select Category dialog, select where you want to 
import the template. You can also create a new category.

4 A standard file browser window opens. Find and select the 
template that you want to import, and then click Open.
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15 Customize Writer

You can customize menus, toolbars, and keyboard shortcuts in 
Writer, and add new menus and toolbars. 

You can add extra functions to Writer by installing extensions 
(add-ons) from the LibreOffice website or from other providers.

This chapter describes some common customizations and 
extensions that you may wish to use.

Note
Customizations can be saved in a template. To do so, first save 
them in a document and then save the document as a template 
as described in Chapter 14. If you work on more than one 
project, you may find that having different menus and toolbars 
can be useful.

Customizing menus and toolbars
You can create new menus and toolbars, add and rearrange items on
the menu bar and toolbars, add items to menus (including context 
menus), and make other changes. Instructions are in the Writer 
Guide.

Assigning shortcut keys
LibreOffice has a general set of keyboard shortcuts that are available
in all components. Also, each component (Writer, Draw, Impress, 
Base, and Math) has its own component-specific set of keyboard 
shortcuts.

You can define other shortcuts for built-in functions or your own
macros and save them for use with all of the components of 
LibreOffice or only with Writer. In most cases you will want to save 
your custom shortcuts only for Writer, because they will be specific 
to your use of Writer.
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Two examples of things that self-publishers might want to assign
to shortcuts are styles and macros.

Example: Assign styles to shortcuts
Some shortcuts, such as Ctrl+0 for the Text body paragraph 

style, Ctrl+1 for the Heading 1 style, and Ctrl+2 for Heading 2, are 
predefined. You can modify these shortcuts and you can create your 
own.

To adapt shortcut keys to your needs, use the Keyboard page of 
the Customize dialog.

Figure 1: Defining keyboard shortcuts for applying styles

1 Choose whether to have the shortcut key assignment 
available in all components of LibreOffice or only in Writer.
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2 Select the desired shortcut key in the Shortcut keys list at the
top of the page.

3 Select the required function from the Category and Function
lists.

4 Click the Modify button. The selection now appears in the 
Keys list on the lower right.

5 Click OK to accept the change.

Example: Assign macros to shortcut keys
A common use for assigning macros to shortcut keys is to enable 
quick and easy insertion of special characters. Our example shows 
how to set up keyboard shortcuts for inserting en-dashes and em-
dashes. (You can also insert these dashes in other ways, as described
in “Inserting dashes” on page 91.)

First, you need to record a macro for inserting each type of dash.
Then, you need to assign those macros to shortcut key 
combinations.

1 Be sure Enable macro recording (may be limited) is selected 
in Tools > Options > LibreOffice > Advanced.

2 Choose Tools > Macros > Record Macro
to start recording a macro.

A small window is displayed so you know that
LibreOffice is recording.

3 Choose Insert > Special Character to open the Special 
Characters dialog. Scroll down until you find the en-dash 
(U+2013) and em-dash (U+2014) characters. Select one of 
them and click OK.

4 Click the Stop Recording button to stop recording, save 
the macro, and display the LibreOffice Basic Macros dialog. 
Type a descriptive name for the new macro in the Macro 
name box on the upper left.

5 In the Save macro in box, in the My Macros list, find the 
library named Standard. Under Standard, select Module1 
and click Save.
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6 Repeat steps 1–4 to create other macros, for example to 
insert an em-dash.

7 Choose Tools > Customize > Keyboard. In the Shortcut 
keys list, pick an unused combination (for example, 
Ctrl+Shift+N for an en-dash). In the Category list, scroll 
down to LibreOffice Macros, click the + sign, then click the +
next to the Standard library and choose Module1. In the 
Function list, choose Endash and click the Modify button 
on the upper right. The selected key combination now 
appears in the Keys list on the lower right.

8 Repeat for the em-dash macro, and then click OK.
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Reset the shortcut keys
To reset all of the keyboard shortcuts to their default values, click 
the Reset button at the bottom of the Customize dialog. Use this 
feature carefully because there is no confirmation dialog before the 
defaults are reset.

Adding functionality with extensions
An extension is a package that adds functions to LibreOffice. For 
example, some dictionary extensions are provided with LibreOffice, 
and many others are available for download from the LibreOffice 
extension repository, http://extensions.libreoffice.org/.
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Some extensions are free of charge. Others are fee based. Check 
the descriptions to see what licenses and fees apply to the ones that 
interest you.

To install an extension:

1 Download the extension and save it anywhere on your 
computer.

2 In Writer, select Tools > Extension Manager from the 
menu bar. In the Extension Manager dialog, click Add.

3 Find and select the extension you want to install and click 
Open. The extension begins installing. You may be asked to 
accept a license agreement.

4 When the installation is complete, the extension is listed in 
the Extension Manager dialog.

180 Chapter 15  Customize Writer



16 Use online publishing 
services

This chapter covers two commonly-used online publishing services:
Lulu, and Kindle Direct Publishing. Both services provide facilities 
for selling printed books and ebooks, and both are free to use.

Friends of Open Document, Inc, the publisher of this book and 
many others about LibreOffice, uses Lulu because its payments 
system is easy for a person or organization not in the USA, but 
Kindle Direct is also popular with non-US residents. Both services 
are good for US residents.

Preparations for online publishing
For any online publishing service, you will need to provide much the
same information: your contact and payment details, information to
define and find the book, and files for the book.

To avoid delays in uploading, gather everything you need before 
you start. You should have:

• An account at the publishing service, with details on how you 
want to be paid.

• Your finished files for the book (PDF and/or ODT or EPUB). 
• The book cover in a separate file.
• A unique ISBN for each version of the book (print or ebook).

Getting an ISBN for your book
An ISBN (International Standard Book Number) is a unique 
identifier for your book. It is usually given in numerals below the 
same numbers in a barcode on the back of the book. 

You do not need an ISBN to publish on Lulu or Kindle Direct, 
but you do need one in order to make your title available for other 
sales and distribution outlets. An ISBN gets your book into Books in
Print and other databases, and registers you as the book’s publisher.
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Note that each version of a book (print, EPUB, MOBI, etc.) needs to 
have its own unique ISBN.

You can find where to purchase and register ISBNs at the 
International ISBN Agency, https://www.isbn-international.org/

Check prices before you buy an ISBN; buying a block of 10 or 
100 may be more cost-effective, especially if you are planning to 
publish several books or several versions of a book. For example, in 
Australia a block of 10 ISBN costs the same as buying two individual
ISBN, so if you need more than one, buy at least 10. 

If you are designing a cover, you can find free software online, or
for Linux, macOS, and Windows for creating a bar code of the ISBN.
If you are using Lulu’s pubishing service, Lulu will provide you with 
a bar code in PDF, which you can include in the cover file.

Using Lulu’s publishing service
Lulu offers the options of selling on their website, through links on 
your own website, or by Lulu’s free “globalREACH” service that puts
your book on Amazon (print and ebooks) and other sales outlets, 
including Apple’s iBookstore (for EPUBs).

To get started, go to https://www.lulu.com/ and click Register 
at the top right (or Login if you have an account). You’ll need your 
name, a valid email address, and a password of your choice. Follow 
the instructions to confirm your email address.

Setting up payment
Once registered and logged in, click My Projects in the top right. 
Before continuing, you may want to read the Creator Revenue FAQ, 
which you’ll find in the My Revenue section in the left-hand column.
The FAQ has a lot of information to help you make some publishing 
and payment choices.
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On the My Projects page, choose Payment Contacts in the My 
Revenue section.

On the Payment Contacts page, choose Edit in the lower right of
the box containing your name. 

On the next page, choose PayPal or Check as the payment 
method. Note: Checks are in US dollars; if you’re depositing them 
in an account in any other currency or country, you may pay a hefty 
bank fee. PayPal may be a more practical choice. Under Taxpayer 
Type, choose Individual or Organization. 

Note
If you choose a free Lulu ISBN for your book, income from sales 
is considered royalties, is reported to the IRS, and US income 
taxes may be withheld. If you are not otherwise subject to US 
income tax, you probably do not want this to happen. 

To avoid US taxation or the need for forms to reclaim tax 
withheld, obtain and use your own ISBN; in that case, tax will 
not be withheld and the income is not reported to the IRS.
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For more information about creator revenues, taxation, and 
necessary forms, see the Lulu website.

Finally, fill in your name, address, and phone number in the 
lower part of the page and click Save Payee Information.

Uploading a book for printing
In the left-hand column, under Start a Project, choose the type of 
book. We’ll look at creating a paperback book first, then an ebook.

First choose a format on the Create Your Print Book page. 

Top of Lulu's Create Your Print Book page
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Bottom of Lulu's Create Your Print Book page

Click the Make this book button in the central section of the 
page.

On the next page, type the Title and Author’s name and choose 
where you want to sell the book. Click Save & Continue.
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Next, specify whether to use an ISBN and, if so, where to get it.

 If you choose Add an ISBN you already own, a box opens 
where you need to type details about you and the ISBN. Fill this in 
and click Save & Continue. 

186 Chapter 16  Use online publishing services



A page with information about what to do with your ISBN and a 
downloadable barcode for one-piece covers displays. Click Save & 
Continue.

On the Add Files page, choose and upload the file for the interior
of your book, which you have prepared in PDF to fit the book size 
you have selected. 

When uploading has finished, click Make Print-Ready File. 
Lulu does a basic check to make sure it is the correct size and 
number of pages and displays a message. (Optional) Click 
Download & Review to confirm your document was converted 
properly and that it looks the way it should. Click Save & 
Continue.

The next step is to create the cover. Be sure your cover images 
meet the “Requirements for All Book Covers” section of Mandatory 
Requirements for Distribution and Cover Formatting on the Lulu 
website.

If you are making a one-piece (wrap-around) cover, you need to 
have added the barcode to the cover. Then click Advanced one-
piece cover designer, read the instructions to ensure your cover 
meets the exact dimensional requirements, choose and upload the 
cover, and click Save & Continue.
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If, instead, you created separate images for the front and back 
covers, Lulu will add a barcode to the back cover. Choose Use the 
old cover designer. You’ll see a a generic cover with the book’s 
title and author, text for the spine, and a barcode on the back. Here 
you have several choices: you can either use images provided by 
Lulu or images of your own; and you can either add the book’s title 
and author on this page or include that information in the image 
you provide.

For this example, we are providing an image that includes the 
title and author.

1 Choose Backgrounds & Pictures under Image Properties 
in the middle of the page.
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2 Click Edit Picture under the thumbnail and upload the 
front cover image you have designed. Cover images should be
in PNG, JPG, or GIF format, with a minimum of 300 dpi.

3 When the image is uploaded, click Accept.

4 Repeat for the back cover image.

5 Back on the Design Your Cover page, the sample front cover 
has two sets of title and author information. To remove the 
ones added by Lulu and show only the ones included in the 
image itself, click Text under Cover Properties.

6 For Front Cover, uncheck Show Title and Show Author. 
For Spine and Back Cover, make any changes you wish. Note
that you can also change the color of text and background 
(relevant mostly to the spine, if you have artwork for both 
covers). You can also choose whether to show the Lulu logo 
on the spine or the URL on the back cover.

7 When the preview is correct, click Make Print-Ready 
Cover, wait for it to finish, then click Save & Continue.

Completing the publishing process
On the Description page, type a description for the book, keywords 
(search terms to help people find it), choose a copyright notice, and 
fill in other fields including Publisher. Click Save & Continue.

On the next page, choose a retail price, including any discount to
be applied for people purchasing on the Lulu site.
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Click Review Project. If anything requires revising, click 
Change or Edit in that section of the page. You can also choose the 
type of distribution (Private, Direct only, or General), which you can
change later.

Click Save & Finish to publish the book. A Congratulations 
page appears, with a large button to Order a Proof Copy.

Click Back to Projects on the upper right to return to your 
project list.

Managing retail distribution of print books
Go to My Projects and click the Manage button next to your newly 
published book. The Manage button displays only if your book 
qualifies for retail distribution.

For print books, you’ll see Get globalREACH Free.

1 Read and accept the distribution terms and conditions.

2 Click I Agree to apply the distribution package to your book.

3 Purchase a proof copy of your book, if you have not already 
done so. When it arrives, review it carefully for errors.

4 Log into your account and approve or deny the book for 
distribution. If you deny the proof copy, you can make 
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revisions to your interior file and/or cover image, upload 
your corrections, and purchase another proof copy.

5 Once you approve your book for distribution, it will be 
available for purchase in retail channels within 6-8 weeks.

Publishing an ebook
First, review Lulu’s mandatory ebook distribution requirements 
(https://connect.lulu.com/en/discussion/33340) and make sure 
your EPUB meets those requirements. Some of these requirements 
are more restrictive than for PDFs used in print books.

Other instructions to read and follow include “EPUB 
Conversion: EPUB Table of Contents (NCX) Preparation” at https://
connect.lulu.com/en/discussion/114439. Lulu’s EPUB Converter 
will create the NCX for you, by scanning your document for Heading
1, Heading 2, and Heading 3 styles. Since an electronic TOC will be 
generated for your ebook, you should remove any TOC pages from 
your manuscript prior to uploading it to the EPUB converter.

Choose eBook under Start a Project. The first steps are the 
same as for a paperback book: title, author, ISBN.

On the Add Files page, you can submit an EPUB that you 
created, or have Lulu create one from your ODT file or other format.

Select and upload a suitable file. When upload is complete, click 
Save & Continue in the lower right (not shown here).
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Then, be patient. You can do something else while Lulu works on
the file.

On your first try, you will probably get an error message from 
Lulu, with instructions on what to do next. When you succeed in 
getting an interior file converted, you’ll see some informational 
messages. Click Save & Continue.

The Marketing Image page is similar to the Cover Design page 
described earlier for print books. It shows a generic cover with the 
book’s title and author.

192 Chapter 16  Use online publishing services



You can either use an image provided by Lulu or an image of 
your own; and you can either add the book’s title and author on this 
page or include that information in the image you provide.

For this example, we are providing an image that include the 
title and author.

1 Choose Backgrounds & Pictures under Image Properties 
in the middle of the page.

2 Click Edit Picture under the thumbnail and upload the 
cover image you have designed. Cover images should be in 
PNG, JPG, or GIF format, with a minimum of 72 dpi, 
approximately 612 pixels wide and 792 px tall. This may be a 
different ratio than used for the cover of a print book.

3 When the background image is uploaded, click Accept.

4 Back on the Design Your Marketing Image page, you’ll see a 
sample cover, in this case with two sets of title and author 
information. To get rid of the ones added by Lulu and show 
only the ones included in the image itself, click Text under 
Image Properties. Uncheck Show Title and Show Author.

5 The cover preview should now be correct. Click Make 
Image in the lower right corner of the page, then click Save 
& Continue.

The Description page is similar to that for print books. The Price 
page is a bit different. Here, in addition to setting a price, you need 
to choose your location. This is for legal and taxation reasons. The 
choices under Select Your Distribution Channels vary with your 
country of residence. Everyone can sell in the Lulu Bookstore. If you
want to delay making the book available, uncheck all the boxes. You 
can return at any time to change your choices.

Lastly, the Review page is similar to that for print books. Check 
the details and click Save & Finish.

Managing distribution of ebooks
Go to My Projects and click the Manage button next to your newly 
published ebook. You’ll see the Manage Distribution page, which is 
similar to Select Your Distribution Channels. Here you can add or 
remove channels for which your book is eligible.
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Using Amazon’s Kindle Direct Publishing
Kindle Direct Publishing uses the same account as other Amazon 
services. If you have bought from Amazon in the past, you can use 
the same account. If not, click the Sign Up button on the Kindle 
home page, https://kdp.amazon.com/en_US/ and follow the 
instructions.

This section summarizes the process. It is adapted from Bruce 
Byfield’s Designing Ebooks, with his permission. For more details, 
see Byfield’s book and the online help for Kindle Direct Publishing.

Setting up account and payment details
For publishing purposes, your Kindle account requires your 
personal, bank and tax information.

In order to receive payment for your sales, you need:
• The name of your bank.
• Your bank’s routing number.
• Your account number.
If necessary, contact your bank for this information.
When you fill in the account information, be sure to indicate that

you want to pay taxes in your own country, if that is what you want. 
Many nations, such as the United States or Canada, have reciprocal 
tax treaties. These treaties mean that, if you have income from 
Amazon.com and are not an American, you can pay taxes on your 
sales in your own country, and not pay them twice.

In the top right of the Kindle Direct home page, click My 
account to log in. Then follow these steps:

1 Enter your personal information.

2 Under Getting Paid, add a bank account where Kindle can 
deposit your money. Consult your bank if necessary.

3 If you choose, set set up different accounts in different 
countries for different Amazon marketplaces (national 
versions of Amazon). You can also set up how and when 
payment will be deposited for you.

4 To enter or view tax information, click the View /Provide 
tax information button on the Tax Information pane. Save
the information already entered on the page before you 
switch screens.
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5 On the Tax Dashboard, click the Tax Information button to 
enter or edit basic tax information. Whether you are an 
individual or a company may affect your taxation rate, while 
whether you are an American citizen determines where you 
will pay tax on income.

6 Enter your personal information, including whether you have
an American TIN or Tax ID. 

7 Click Continue to enter the informaton on the page. Any 
fields you have accidentally missed will be marked in red.

8 Back on the Tax Dashboard, select whether to receive paper 
or paperless accounts. Just before taxes are due, Americans 
can also view relevant tax forms.

9 Click Exit to return to the My Account page.

10 Click Save to return to the main Kindle page.

The information you enter will be used for all the books you 
upload.

Entering book information
This information is specific to each book.

1 From the main page, click Add a New Title. Choose whether 
to create a Kindle eBook or a paperback book.

2 Enter your book details. Ignore any that are irrelevant. The 
following panes are available:

• Language
• Book Title: Include any sub-title.
• Series: The Series’ name and this book’s number in the 

series.
• Edition: This information can be important because some

readers collect editions, especially first ones.
• Author.
• Contributors: Usually only used for anthologies and other

collections.
• Description: A blurb that will be used on Amazon. Up to 

4000 characters can be used.
• Publishing Rights: A declaration of whether you own the 

rights or not. 
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• Keywords: Seven tags that will help readers find the book.
Keywords can be phrases, not just single words.

• Categories: Two categories to classify your book under in 
searches. Categories are chosen from a pre-defined list.

• Age and Grade Range: Stats that can help target your 
book if it is intended for children or young adults.

• Pre-Order: Whether pre-orders are allowed. After 
publication, this category is irrelevant.

3 Click the Save and Continue button to move on to details 
for the book. For ebooks, you can set:

• Manuscript: Whether the book uses DRM (Digital Rights 
Management) to prevent copying, and the uploading of 
the book. Supported formats are listed, and the file is 
converted to .MOBI format, the format used by Kindle. 
The page indicates whether the upload is successful, and 
whether any possible spelling errors were found, offering 
you a chance to view them.

• Kindle eBook Cover: Upload a cover or have Kindle 
produce a cover for you. Using your own cover is 
recommended. The page indicates if the upload of your 
cover is successful.

• Kindle eBook Preview: Check the appearance of the book, 
either on your computer or on a Kindle eBook reader.

• Kindle eBook ISBN: Add an optional eBook and Publisher
(see “Getting an ISBN”).

When you are finished, click the Continue button to enter 
pricing.
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Setting pricing
Pricing is set for the first time after you complete Book Details.  

If you want to edit later on, select Edit ebook pricing from the 
Kindle ebook options the right of the cover and title.

You can set:
• KDP Select Enrollment: Your participation in Kindle’s 

promotional program.
• Territories: Whether you own world-wide rights, or rights in 

specific territories.
• Royalty and Pricing: Royalties are the money you receive 

from sales. Books under $10 can be set at 70% royalties to 
compensate for the lower price. Books over $9.99 must be set
at 35%. You can set different prices in different Amazon 
marketplaces.

• Matchbook: Whether you participate in a program in which 
buyers of a hardcopy of your book have the option of buying 
the ebook at a reduced rate.

• Booklending: Whether you participate in a program in which 
buyers of the ebook can let others borrow it for 14 days.

• Terms and conditions: Your agreement to Kindle’s terms of 
sales.

When you are ready, click the Publish Your Kindle ebook 
button on the bottom of the page. It may take several minutes to 
finish processing the ebook. Meanwhile, the site returns to the main 
page. Your ebook will typically be available within 72 hours.
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